KVM boot error Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
hd888
Posts: 21
Joined: Fri Apr 06, 2018 2:56 pm

KVM boot error

Post by hd888 »

I downloaded the DietPi BIOS IMG file and I am attempting to get it to boot in KVM and I get this error. Any ideas?
Screenshot from 2020-06-20 12-06-28.png
I have already resized img file to 10 GB and made no other changes to the default settings in KVM. I found a few similar issues on the web but nothing has worked so far...
hd888
Posts: 21
Joined: Fri Apr 06, 2018 2:56 pm

Re: KVM boot error

Post by hd888 »

For future reference the post by LeoFender got it going

https://forums.unraid.net/topic/72708-d ... ll-on-kvm/

I was not able to do it with img file (probably don't know how to resize it properly)

I had to start with VBox and work it backwards from there...
User avatar
Joulinar
Posts: 2074
Joined: Sat Nov 16, 2019 12:49 am

Re: KVM boot error

Post by Joulinar »

Hi,

sorry for the late response but it took some time for me to get a Linux system up and running to have KVM installed. At the end I had a Windows computer hosting Ubuntu inside VirtBox. And this Ubuntu VM was hosting my KVM system :D

Long story short, I had the same issue using x68 image file. However I worked around stating with a plain Debian installation and installed DietPi on top using PREP script.

https://github.com/MichaIng/DietPi/issues/1285

picture.png
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
hd888
Posts: 21
Joined: Fri Apr 06, 2018 2:56 pm

Re: KVM boot error

Post by hd888 »

Thanks Joulinar,

I considered doing that after seeing the prep script on Github during my searches. Probably faster to resize via vbox image. Maybe when I get a free moment ill check out resizing a raw image and maybe do a tutorial. I have a feeling that's where the problem was occurring. Kinda funny that we're running Debian based DP and yet no KVM VM option! Oh well, no biggie!

Check out the forum link i posted, it's pretty good to get it going from the vbox OVA file.
User avatar
Joulinar
Posts: 2074
Joined: Sat Nov 16, 2019 12:49 am

Re: KVM boot error

Post by Joulinar »

I guess I will talk to developer. Probably it can be added to VM section. Will see.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply