Using Pi-Hole with hostap wireless access point

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
pi-monger
Posts: 1
Joined: Fri Jun 05, 2020 6:23 am

Using Pi-Hole with hostap wireless access point

Post by pi-monger »

I have setup Diet-Pi on RP-3B+ to run hostap and pihole. pihole only works on clients connected via LAN but all clients which connect to hostap wireless access point do not show up on dashboard.

I have configured Settings to use Cloudfare DNS and allow and from all origins for the LAN connection but still no Pi-Hole for wireless clients.

Do I need to setup the DNS for hostap to point to pi-hole which uses same ip address? Thanks for any help. 8)
User avatar
Joulinar
Posts: 2044
Joined: Sat Nov 16, 2019 12:49 am

Re: Using Pi-Hole with hostap wireless access point

Post by Joulinar »

Hi,

many thanks for your request. Your WiFi HotSpot is providing an own subnet with own IP address range, own DHCP and DNS config. Therefore you would need to specify the PiHole DNS Server within HotSpot DHCP Server config

Code: Select all

nano /etc/dhcp/dhcpd.conf
There you would need to change option domain-name-servers to point to your PiHole. If you running the standard setup, it's same as option routers 192.168.42.1. Once done save the file and restart DHCP server.

Code: Select all

systemctl restart isc-dhcp-server.service
To get new DNS settings on your device, you would need to reconnect to WiFi. Within PiHole you would need to set DNS Server to Listen on all interfaces, permit all origins.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply