Back-up/Update Fail

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
User avatar
finch_6
Posts: 33
Joined: Tue Sep 04, 2018 7:21 pm

Back-up/Update Fail

Post by finch_6 »

Hi all,

I had trouble upgrading Dietpi yesterday and thought I would give it another try today... But before I upgraded now, I tried a backup...
But I'm getting the same error...
Screenshot 2020-05-13 at 20.01.24.png
Screenshot 2020-05-13 at 20.01.56.png
Any ideas anyone??
DietPi on a Raspberry Pi 3 B+ running:
- Sonarr
- Deluge
- Jackett
User avatar
Joulinar
Posts: 2085
Joined: Sat Nov 16, 2019 12:49 am

Re: Back-up/Update Fail

Post by Joulinar »

Hi,

many thanks for your report. It's not really the DietPi update or backup that is going to fail. It's more the standard Debian apt-get upgrade that's going to fail. apt-get is called in front of DietPi update to ensure that all Debian packages are up-to-date. In case of DietPi backup, apt-get is called to install rsync that is needed to perform the backup.

Anyway in both cases apt-get is going to fail as you have a source included that doesn't seems to have a valid release file.
picture.PNG

looks like your source list is pointing the a snapshot. Probably a daily snapshot that was refreshed at this moment. At least it would fit, looking to the time stamp of the file.
picture1.PNG

Probably you can try to running apt update and apt upgrade again manually, to check if it would be working now.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply