Mosquitto issue

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
scargill
Posts: 16
Joined: Sat Oct 15, 2016 11:03 pm

Mosquitto issue

Post by scargill »

This is an interesting one which I thought I would bring to your attention though I realise you can't support any software that anyone throws at you.

For some time now on many boards I have always installed Mosquitto with Websockets... and it has always worked without issue.

Two of us have now tried this with the same results - installing Mosquitto with Websockets on DietPi - it works just as normal... however it does not start automatically on power up.

Using Webmin you can see that the service is there. You can RESTART the service - and it starts - no problem, - but....it will not start up on it's own on powerup.

We have a way around it - to take the "restart" part of the startup script - put it into /etc/rc.local - and it works perfectly but this is not ideal really.

Anyone have any thoughts as to why this might be?? ONLY in DietPi - works fine on a standard Raspberry Pi, or with a "standard" Armbian distribution.

Pete.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Mosquitto issue

Post by Fourdee »

scargill wrote:Two of us have now tried this with the same results - installing Mosquitto with Websockets on DietPi - it works just as normal... however it does not start automatically on power up.
Hi Pete,

How are you installing Mosquitto on the DietPi system?

Can you also please paste the contents of the mosquitto service (eg: /etc/init.d) ? I'll take a look.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply