IPv6 not working without "prefer IPv4" option

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
markfree
Posts: 3
Joined: Wed May 06, 2020 1:53 am

IPv6 not working without "prefer IPv4" option

Post by markfree »

With a minimal installment, after first boot, while checking configs, I noticed an odd behavior with network options under Dietpi-Config.

If I leave "Prefer IPv4" ON, I get IPv6 address.

Code: Select all

●─ Additional Options ───────────●
IPv6        : [On]
Prefer IPv4 : [On]
If I turn "Prefer IPv4" OFF, IPv6 is not available.

Code: Select all

●─ Additional Options ───────────●
IPv6        : [On]
Prefer IPv4 : [OFF]
I have a fully enabled IPv6 network with a DHCPv6 and all my devices get IPv6 without a problem.
So, I prefer to leave option "Prefer IPv4" set to OFF.

Is there a way to correct that behavior?

Thanks
trendy
Posts: 125
Joined: Tue Feb 25, 2020 2:54 pm

Re: IPv6 not working without "prefer IPv4" option

Post by trendy »

On all 4 of my devices running dietpi I have IPv6 On and preferred.
The only issue is that DHCPv6 doesn't work yet, so you'll have to depend on SLAAC only, or do a small workaround until it is fixed in the next version.
Post Reply