Rtorrent not working

Having issues with your DietPi installation, or, found a bug? Post it here.
vorrac
Posts: 8
Joined: Tue Jan 30, 2018 2:21 pm

Re: Rtorrent not working

Post by vorrac »

It didn’t work, tried port forwarding, DMZ, edit the .rtorrent like the video. Unfortunately it didn’t work. I’m using a tp-link eifi mesh router and it created a sub network with different ips. I don’t know if this is the problem, woll try connecting odroid directly to ISP modem/router.
vorrac
Posts: 8
Joined: Tue Jan 30, 2018 2:21 pm

Re: Rtorrent not working

Post by vorrac »

It’s not working. I’ve tried everything I know. :cry:
User avatar
Joulinar
Posts: 2059
Joined: Sat Nov 16, 2019 12:49 am

Re: Rtorrent not working

Post by Joulinar »

What does the WebUi tells if you move your mouse over the red bubble?

For me it's like this
picture1.PNG
picture1.PNG (8.81 KiB) Viewed 386 times


and once I open the port on my router, it will be set to green (after refresh the status)
picture2.PNG
picture2.PNG (8.96 KiB) Viewed 386 times
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
vorrac
Posts: 8
Joined: Tue Jan 30, 2018 2:21 pm

Re: Rtorrent not working

Post by vorrac »

Exactly the same thing as the first image.
User avatar
MichaIng
Site Admin
Posts: 2293
Joined: Sat Nov 18, 2017 6:21 pm

Re: Rtorrent not working

Post by MichaIng »

Hey guys, many thanks for reporting and debugging the issue. Indeed there was a bug our side where we set max memory allocation without adding an "M" for MiB, so I guess the effective value is in KiB now which is of course much too low. Fix is up: https://github.com/MichaIng/DietPi/pull/3531
We'll as well hack this inside v6.30 systems via MOTD, to prevent future users from running into this, until v6.31 release.

Now I am not sure how DHT is related. Probably because it simply requires additional allocated memory. Could you guys try to leave DHT enabled after fixing the max memory string by adding a "M"? Maintaining a "distributed hash table" for trackerless torrents by default makes rTorrent more compatible without the need for user action. Not sure how well "auto" handles it, but of course, if keeping it enabled causes still issues, we'll revert to "auto".
vorrac
Posts: 8
Joined: Tue Jan 30, 2018 2:21 pm

Re: Rtorrent not working

Post by vorrac »

MichaIng wrote: Tue May 12, 2020 11:42 am Hey guys, many thanks for reporting and debugging the issue. Indeed there was a bug our side where we set max memory allocation without adding an "M" for MiB, so I guess the effective value is in KiB now which is of course much too low. Fix is up: https://github.com/MichaIng/DietPi/pull/3531
We'll as well hack this inside v6.30 systems via MOTD, to prevent future users from running into this, until v6.31 release.

Now I am not sure how DHT is related. Probably because it simply requires additional allocated memory. Could you guys try to leave DHT enabled after fixing the max memory string by adding a "M"? Maintaining a "distributed hash table" for trackerless torrents by default makes rTorrent more compatible without the need for user action. Not sure how well "auto" handles it, but of course, if keeping it enabled causes still issues, we'll revert to "auto".
I've reinstalled everything and tried. I had to change DHT to auto otherwise rtorrent wouldn't start, giving an invalid argument error.
User avatar
MichaIng
Site Admin
Posts: 2293
Joined: Sat Nov 18, 2017 6:21 pm

Re: Rtorrent not working

Post by MichaIng »

Ah lol, indeed "enable" is not a valid value, "on" is instead: https://github.com/rakshasa/rtorrent/bl ... c#L99-L104
Post Reply