Bad IMG? Asus Tinker Board

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
User avatar
ryancedgar
Posts: 5
Joined: Mon May 04, 2020 4:48 am

Bad IMG? Asus Tinker Board

Post by ryancedgar »

I'm having trouble writing a mountable SD card. I've tried writing the DietPi img for the Asus Tinker Board with both Rufus and Etcher. The resulting disk will not mount on Windows at all. Has anyone else been having this problem?

This last week I wrote the DietPi img for my RPi 3b+ and it mounted on Windows, I edited it, and it booted on my RPi no problem.

It seems like I can open the img fine on my Windows machine with 7zip. Is it possible to partition and format the card manually and then just copy the files from the img over?
User avatar
Joulinar
Posts: 2068
Joined: Sat Nov 16, 2019 12:49 am

Re: Bad IMG? Asus Tinker Board

Post by Joulinar »

Hi,

many thanks for your report. usually partition should be created in ext4 format and by design Windows is not able to read ext4. You could try to connect you device to another Linux box like your RPi and check it there. Or you are going to install some ext4 extension on your Windows system
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
ryancedgar
Posts: 5
Joined: Mon May 04, 2020 4:48 am

Re: Bad IMG? Asus Tinker Board

Post by ryancedgar »

Thanks for the reply, Joulinar. I guess I assumed that there would be a FAT32 /boot partition in addition to the root / partition like on the RPi images. But what you are saying makes sense. I'll give that a shot, thanks.

EDIT: So I plugged the SD card USB dongle into my RPi:

# mount /dev/sda /mnt/sda
mount: /mnt/sda: wrong fs type, bad option, bad superblock on /dev/sda, missing codepage or helper program, or other error.

# fdisk -l
Disk /dev/sda: 29.8 GiB, 32010928128 bytes, 62521344 sectors
Disk model: Storage Device
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos

# blkid
/dev/sda: PTUUID="####xxxx" PTTYPE="dos"

UUID obfuscated, underlines added emphasis mine. Any assistance anyone can provide is appreciated.
User avatar
ryancedgar
Posts: 5
Joined: Mon May 04, 2020 4:48 am

Re: Bad IMG? Asus Tinker Board

Post by ryancedgar »

Never mind, I guess I got like 5 or 6 bad writes in a row ¯\_(ツ)_/¯. Tried again and now I have a part that will mount on my RPi. Thanks!
User avatar
Joulinar
Posts: 2068
Joined: Sat Nov 16, 2019 12:49 am

Re: Bad IMG? Asus Tinker Board

Post by Joulinar »

so it's working now?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply