[dupe] XU4 fails to power on

Having issues with your DietPi installation, or, found a bug? Post it here.
Locked
nphil

[dupe] XU4 fails to power on

Post by nphil »

Please see the following thread if you are experiencing XU4 power on issues: http://dietpi.com/phpbb/viewtopic.php?f=11&t=707


I've been having this issue where my XU4 will not start back up after powerloss/improper shutdown. This is with Dietpi installed on the 8GB EMMC. Only Red light, no blinking blue light.

I tested this with ubuntu 16.04 and it starts right back up when I pulled the power plug and replugged, as expected. I have to completely reflash the emmc every time I have an unplanned shutdown/powerloss (tested this many times) :oops:

Something is corrupting the EMMC on improper shutdowns on Dietpi, something that doesn't seem to happen with other distros.

This is on a cloudshell with an attached 256GB SSD.

Is this a known issue? I remember this not being a problem with earlier versions of dietpi, I upgraded recently and this started happening,.
delaerp

Re: XU4 fails to boot back up after improper shutdown

Post by delaerp »

I got a simular problem with version 132, you can solve the problem as in this post :http://dietpi.com/phpbb/viewtopic.php?f=11&t=707
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: XU4 fails to boot back up after improper shutdown

Post by Fourdee »

nphil wrote: Something is corrupting the EMMC on improper shutdowns on Dietpi, something that doesn't seem to happen with other distros.
Hi nPhil,

Improper shutdown, will most likely corrupt the eMMC.
As for why this is only occurring on your DietPi installation, doesn't make sense yet. Possible the kernel config is slightly different, or your running software on the DietPi installation that has high disk writes to EMMC, aside from that, not sure.
I tested this with ubuntu 16.04 and it starts right back up when I pulled the power plug and replugged, as expected. I have to completely reflash the emmc every time I have an unplanned shutdown/powerloss (tested this many times)
Which kernel version is the Ubuntu image running?

Code: Select all

uname -a
Which software do you have installed and running on the DietPi installation?
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
nphil

Re: XU4 fails to boot back up after improper shutdown

Post by nphil »

Fourdee wrote:
nphil wrote: Something is corrupting the EMMC on improper shutdowns on Dietpi, something that doesn't seem to happen with other distros.
Hi nPhil,

Improper shutdown, will most likely corrupt the eMMC.
As for why this is only occurring on your DietPi installation, doesn't make sense yet. Possible the kernel config is slightly different, or your running software on the DietPi installation that has high disk writes to EMMC, aside from that, not sure.
I tested this with ubuntu 16.04 and it starts right back up when I pulled the power plug and replugged, as expected. I have to completely reflash the emmc every time I have an unplanned shutdown/powerloss (tested this many times)
Which kernel version is the Ubuntu image running?

Code: Select all

uname -a
Which software do you have installed and running on the DietPi installation?

Thanks for your repsonse, I'm really hoping to fix this issue without some sort of a bandaid/dirty hack. I tested the high disk writes to EMMC theory a couple of different ways: clean installation of dietpi with nothing installed. Waited a while and pulled the plug, won't reboot. reboot command works fine. Also tried pulling the plug after 2-3 seconds after issuing the reboot command, won't start back up.

Either way I have it setup with all my software and stuff installed (this takes about 1 hour every time) and I'm scared to even touch the damn thing because if it goes off, I have to redo my entire setup again every time.

I'm not sure which kernel version the ubuntu image I tested was running, it was the one available from the official odroid website, and I did a apt-get upgrade

What confuses me is why everything was working perfectly a while ago on an older version of dietpi, it's only the most recent upgrade that started doing this.

One a related note, is there any way to clone my emmc (as a disk image file that I can restore later) without taking it out of my ODROID (can't take it out without turning off ODROID, which corrupts the emmc anyway), or unmounting it? I want to make a backup of my setup so I can keep testing without spending hours setting stuff up everytime. Maybe boot from microSD and clone the emmc?
Last edited by nphil on Fri Oct 14, 2016 7:46 pm, edited 2 times in total.
nphil

Re: XU4 fails to boot back up after improper shutdown

Post by nphil »

delaerp wrote:I got a simular problem with version 132, you can solve the problem as in this post :http://dietpi.com/phpbb/viewtopic.php?f=11&t=707

thanks, I will try this when I get home.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: XU4 fails to boot back up after improper shutdown

Post by Fourdee »

What confuses me is why everything was working perfectly a while ago on an older version of dietpi, it's only the most recent upgrade that started doing this.
Yep, strange, we've not done any XU4 specific changes to our image in a while.

Note to self: XU4 kernel has been updated recently:

Code: Select all

root@DietPi-XU4:~# uname -a
Linux DietPi-XU4 3.10.103+ #1 SMP PREEMPT Sat Sep 3 10:17:24 CEST 2016 armv7l GNU/Linux

apt-get update
apt-get upgrade -y

root@DietPi-XU4:~# uname -a
Linux DietPi-XU4 3.10.103+ #1 SMP PREEMPT Tue Oct 11 17:49:42 CEST 2016 armv7l GNU/Linux
I'am not implying the kernel is the issue here, it could be something DietPi or I has done that i'am not aware of yet, but either way, its a change we might need to investigate

Unfortunately, i'am not willing to unplug the power on my device for testing and replicating this issue, as its currently in use as a backup server.
thanks, I will try this when I get home.
If the .dtb works, please let us know. Will give us an area to look into.
One a related note, is there any way to clone my emmc
Yes, if your using windows, you can use win32 disk imager and read the EMMC to a image file. Then when you want to restore the image, simply select your image and select write.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
nphil

Re: XU4 fails to boot back up after improper shutdown

Post by nphil »

Yes, if your using windows, you can use win32 disk imager and read the EMMC to a image file. Then when you want to restore the image, simply select your image and select write.
I tried doing this by issuing a shutdown -h now yesterday to shutdown cleanly and remove the emmc, but it still wouldn't boot back up (wtf??). Maybe the issue is not with data corruption but something changing after dietpi upgrades itself, preventing it from booting up from a full shutdown? I will test later today by not letting dietpi upgrade and unplugging/replugging.

I'm basically stuck in this state and can only reboot. This is why i wanted to make the image without removing the emmc or shutting down, but can i make an image of a drive without unmounting it?

btw, exynos5422-odroidxu3.dtb is already in /boot for me. Could someone tell me how to revert to kernel 3.10.96?
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: XU4 fails to boot back up after improper shutdown

Post by Fourdee »

Could someone tell me how to revert to kernel 3.10.96?

Code: Select all

apt-get purge linux-image-* #say no to abort removal
apt-get install linux-image-3.10.96+
reboot
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: XU4 fails to boot back up after improper shutdown

Post by Fourdee »

Phil, could you please answer the following questions on this post: http://dietpi.com/phpbb/viewtopic.php?f ... 3337#p3337 Thanks.

I'll mark this thread as closed, please post your reply in the link above.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Locked