Odroid C1+ Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
User avatar
MichaIng
Site Admin
Posts: 2293
Joined: Sat Nov 18, 2017 6:21 pm

Re: Odroid C1+

Post by MichaIng »

The following commit should enable CPU temp support for the new Odroid C1 image: https://github.com/MichaIng/DietPi/comm ... 78fa8a831e
The '/sys/class/hwmon/hwmon0/temp1_input' is all the needs to be added, I just made some other coding enhancements along with this.
Raoul
Posts: 14
Joined: Thu May 14, 2020 8:03 pm

Re: Odroid C1+

Post by Raoul »

It works, I add those lines in dietpi-global and after reboot:
Image
Another bad news, I can't enable i2c
modprobe aml_i2c returns:modprobe: FATAL: Module aml_i2c not found in directory /lib/modules/5.4.41-meson
any idea how to add this module?
Esit: module spicc too. but it's also the case on original armbian.
Last edited by Raoul on Tue May 19, 2020 9:53 pm, edited 1 time in total.
biagioD
Posts: 10
Joined: Sat Jul 27, 2019 6:27 pm

Re: Odroid C1+

Post by biagioD »

Hi at all. I try this version of dietpi but my odroid c1 doesn't work. The blue led blink slowly and the monitor is black.
Raoul
Posts: 14
Joined: Thu May 14, 2020 8:03 pm

Re: Odroid C1+

Post by Raoul »

Hi biagioD,
I think that's a problem from original armbian image I saw a post on their forum , that someone is in your case.
https://forum.armbian.com/topic/13888-odroid-c1-s805/
I can't test it because I broke my hdmi port some years ago.
biagioD
Posts: 10
Joined: Sat Jul 27, 2019 6:27 pm

Re: Odroid C1+

Post by biagioD »

Yes is true, there are some problem with hdmi.
I connect to the odroid c1 throug ssh connection and work fine, there are some problem but work.
1 problem is in the connection.
The odroid is connected throug ethenet connection, but when I try in ssh and the wifi usb dongle is inserted I have disconnection from ssh

I have to disconect usb dongle and then I'm able to connect in ssh, then I inserted usb dongle and config wifi, after that I always connected throug wifi.

2 problem is with display option.
I try some setting in boot.ini but the monitor is all black. I try to setting the monitor option throug diet-config but I have the error "This option is not avaible"

Another problem is the ping to dns9.quad9.net, on the odroid this command

Code: Select all

ping -c 1 -W 10 dns9.quad9.net
not work, in my pc that are in the same lan work
Attachments
Istantanea.png
Istantanea-1.png
biagioD
Posts: 10
Joined: Sat Jul 27, 2019 6:27 pm

Re: Odroid C1+

Post by biagioD »

I modified this command

Code: Select all

ping -c 1 -W 10 dns9.quad9.net
in this way

Code: Select all

ping -c 1 -W 10 -4 dns9.quad9.net
Now it's work, I'm able to see dietpi-softaware
User avatar
Joulinar
Posts: 2049
Joined: Sat Nov 16, 2019 12:49 am

Re: Odroid C1+

Post by Joulinar »

Did you have IPv6 active on your DietPi device? Probably you can have it deactivated. This way you would not need to force IPv4 ping check.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
biagioD
Posts: 10
Joined: Sat Jul 27, 2019 6:27 pm

Re: Odroid C1+

Post by biagioD »

Joulinar wrote: Tue May 26, 2020 11:33 am Did you have IPv6 active on your DietPi device? Probably you can have it deactivated. This way you would not need to force IPv4 ping check.
I do this command

Code: Select all

root@DietPi:~# test -f /proc/net/if_inet6 && echo "IPv6 supported" || echo "IPv6 not supported"
IPv6 supported
Also I ping my pc with this command

Code: Select all

root@DietPi:~# ping6 2001:b07:***********:edc7
PING 2001:b07:***********:edc7(2001:b07:***********:edc7) 56 data bytes
64 bytes from 2001:b07:***********:edc7: icmp_seq=1 ttl=64 time=5.10 ms
It work
biagioD
Posts: 10
Joined: Sat Jul 27, 2019 6:27 pm

Re: Odroid C1+

Post by biagioD »

It's very strange, I don't do nothing and now it's work

Code: Select all

root@DietPi:~# ping6 -c 1 -W 10  dns9.quad9.net
PING dns9.quad9.net(2620:fe::fe:9 (2620:fe::fe:9)) 56 data bytes
64 bytes from 2620:fe::fe:9 (2620:fe::fe:9): icmp_seq=1 ttl=59 time=14.9 ms

--- dns9.quad9.net ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 14.901/14.901/14.901/0.000 ms
User avatar
Joulinar
Posts: 2049
Joined: Sat Nov 16, 2019 12:49 am

Re: Odroid C1+

Post by Joulinar »

maybe a temp issue with IPv6 connectivity?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Post Reply