Slow Pi3 B+ NAS after HDD Upgrade

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
webodan
Posts: 1
Joined: Sun Mar 08, 2020 1:48 am

Slow Pi3 B+ NAS after HDD Upgrade

Post by webodan »

Hi,

I've been using DietPi as a NAS using Samba and NTFS-3G with one of those Maxtor 2.5" USB3, 2TB drives.
Despite the somewhat slow transfer speed, the convenience of having a low power, reliable server (that does a couple other things not relevant to this post) definitely won me over.

However, the drive eventually ran out of space and, since this setup has worked so well, I decided upgrade it for a brand new 3.5" 6TB Seagate Expansion Drive, which I've finally been able to use since migrating the data took literally half a day to clone over.

Since then, I've experienced reduced bandwith when receiving files from the NAS (will start at the usual 10.9 MB/s, then start dropping bit by bit, ending up as low as 4MB/s!), and also when seeking videos from it using Kodi. I literally can't seek in big 1080p or 720p 5-6GB movies (it will freeze when trying to seek). I also noticed how folders also take longer to pop up than before, which was instantly.

I'm not very experienced in messing around with Samba, so I wondered if I could get some tips into what exactly is wrong with this drive - all i did was clone my data over, expand my NTFS partition and then run ntfsfix on it because Linux complained about some MFT thing being bad. The older drive, despite using power from the Pi3, ran great compared to this one, which I did not expect considering the newer uses a separate power supply for itself.

Im posting my fstab and smb.conf:

Code: Select all

# Please use "dietpi-drive_manager" to setup mounts
#----------------------------------------------------------------
# NETWORK
#----------------------------------------------------------------


#----------------------------------------------------------------
# TMPFS
#----------------------------------------------------------------
tmpfs /tmp tmpfs defaults,size=1023M,noatime,nodev,nosuid,mode=1777 0 0
tmpfs /DietPi tmpfs defaults,size=10m,noatime,nodev,nosuid,mode=1777 0 0

#----------------------------------------------------------------
# MISC: encryptfs, vboxsf (VirtualBox shared folder), bind mounts
#----------------------------------------------------------------


#----------------------------------------------------------------
# SWAPFILE
#----------------------------------------------------------------


#----------------------------------------------------------------
# PHYSICAL DRIVES
#----------------------------------------------------------------
PARTUUID=7f3ba456-02 / auto defaults,noatime,rw 0 1
PARTUUID=7f3ba456-01 /boot auto defaults,noatime,rw 0 1
#/var/swap none swap sw 0 0
tmpfs /var/log tmpfs defaults,size=50m,noatime,nodev,nosuid,mode=1777 0 0
UUID=01D5F4CDC853DD30 /mnt/maxtor ntfs-3g defaults,uid=1001,gid=1001 0 0

###### this is how the old drive was mounted, i only changed the UUID so it would mount the new one btw #####

Code: Select all

[global]
        max log size = 1000
        workgroup = WORKGROUP
#### these lines here were added in an attempt to optimize the slow seek performance. 
#### sadly, to no avail: they even made the server slower!
       socket options=SO_RCVBUF=131072 SO_SNDBUF=131072 IPTOS_LOWDELAY TCP_NODELAY
        min receivefile size = 16384
        use sendfile = true
        aio read size = 16384
        aio write size = 16384
 ####       
     
        
[MaxtorNet]

        lanman auth = yes
        ntlm auth = yes
        comment = maxtor
        path = /mnt/maxtor
#       create mask = 0660
        create mask = 0644
        create mask = 0755
#       directory mask = 0771
        force group = dietpi
        force user = pi
        read only = no
        writeable = yes
        valid users = pi
        
Hope we can sort this out. I'd really appreciate it.

Thanks in advance!
Reds
Posts: 14
Joined: Thu Feb 20, 2020 5:59 pm

Re: Slow Pi3 B+ NAS after HDD Upgrade

Post by Reds »

NTFS is slow on Pi’s. Do you have to use it? Try EXT4 instead. Much faster.
Post Reply