Dietpi not connected Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Thor
Posts: 16
Joined: Thu May 23, 2019 9:02 pm

Re: Dietpi not connected

Post by Thor »

Ok, can i reinstall it via ssh?
User avatar
Joulinar
Posts: 2068
Joined: Sat Nov 16, 2019 12:49 am

Re: Dietpi not connected

Post by Joulinar »

Yep but first we need to switch DNS setting from local 127.0.0.1 to a public one like 1.1.1.1 or 8.8.8.8 to be able to download the new PiHole software.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Thor
Posts: 16
Joined: Thu May 23, 2019 9:02 pm

Re: Dietpi not connected

Post by Thor »

Ok, i changed in sudo nano /etc/network/interfaces
the dns-namservers from 1.1.1.1. 1.0.0.1. to 8.8.8.8.

Code: Select all

# Please modify network settings via: dietpi-config
# Or create your own drop-ins in: /etc/network/interfaces.d/

# Drop-in configs
source interfaces.d/*

# Local
auto lo
iface lo inet loopback

# Ethernet
allow-hotplug eth0
iface eth0 inet static
address 192.168.178.30
netmask 255.255.255.0
gateway 192.168.178.1
dns-nameservers 8.8.8.8.

# WiFi
#allow-hotplug wlan0
iface wlan0 inet dhcp
address 0.0.0.0
netmask 0.0.0.0
gateway 0.0.0.0
#dns-nameservers 0.0.0.0
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
Then i restart, but this doesn´t help. When I log in via ssh i get in the Header this:

Code: Select all

 DietPi v6.28.0 : 21:22 - Mi 04.03.2020
 ─────────────────────────────────────────────────────
 - Device model : RPi 3 Model B+ (armv7l)
 - CPU temp : 39'C : 102'F (Cool runnings)
 - LAN IP : 192.168.178.30 (eth0)
curl: (6) Could not resolve host: dietpi.com
 ────────────────────────────────────────────────
If you can't make it today, it's no problem. It's late here too :)
User avatar
Joulinar
Posts: 2068
Joined: Sat Nov 16, 2019 12:49 am

Re: Dietpi not connected

Post by Joulinar »

you have a config error on your /etc/network/interfaces. One single DOT to much at the end of the DNS Server config 8)

Code: Select all

dns-nameservers 8.8.8.8.
ok pls try to stop and disable pihole-FTL.service first

Code: Select all

systemctl stop pihole-FTL.service
systemctl disable pihole-FTL.service
Once done, do the following
  1. dietpi-config
  2. got to 7 : Network Options: Adapters
  3. got to Ethernet
  4. set Change Mode : [STATIC]
  5. set Static DNS : [1.1.1.1 1.0.0.1]
  6. Apply
  7. exit dietpi-config
  8. on console check if DNS Server is now 1.1.1.1 > nslookup google.de
  9. reboot your system
  10. once done lets reinstall PiHole > dietpi-software reinstall 93
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Thor
Posts: 16
Joined: Thu May 23, 2019 9:02 pm

Re: Dietpi not connected

Post by Thor »

Hey Joulinar,
thanks a lot, that worked out great. I was able to reinstall pi-hole and now pi-hole runs very well again.

many thanks a lot 8)
Post Reply