Install AnyDesk Version 5 ?

Having issues with your DietPi installation or found a bug? Post it here.
Post Reply
att2
Posts: 15
Joined: Tue Jan 07, 2020 12:42 pm

Install AnyDesk Version 5 ?

Post by att2 »

Hello,
I am trying to install AnyDesk 5.1.1.1 or higher on a Odroid C2 with DietPI (latest version).
I found out by trial-and-error that only the very old version of AnyDesk , namely AnyDesk 2.9.4-1_armhf is working properly with DietPI (anydesk_2.9.4-1_armhf.deb, 1.864.774 bytes).
I failed to properly install any Anydesk 5.x versions. They get larger and need more libraries; but then they won't be able to be remote controlled properly, I get all sort of errors , like "display_driver_not_supported" etc.

Has anyone of you been able to install higher "Anydesk" versions on DietPI and if so, how ?
themagicm
Posts: 12
Joined: Sat Apr 18, 2020 6:05 am

Re: Install AnyDesk Version 5 ?

Post by themagicm »

No. I get some error: "libegl dri2 failed to authenticate"
I cannot Anydesk from my linux laptop to dietpi either because of Wayland on the dietpi. So I jump from my Windows box to Dietpi running 2.9.4
User avatar
MichaIng
Site Admin
Posts: 2924
Joined: Sat Nov 18, 2017 6:21 pm

Re: Install AnyDesk Version 5 ?

Post by MichaIng »

DietPi does not ship wayland with any install option. All is based on X.Org-X-Server. I guess it's some library incompatibility between AnyDesk 5 and older Debian version like Stretch.
libegl dri2 failed to authenticate
That sounds like a permissions issue. Try to either run it as root user, or add the user to video + render system groups. Not sure how AnyDesk is exactly executed on server, so with some details we could give some more detailed instructions :).
Post Reply