Wireguard Installation Problem

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
DevinAK
Posts: 7
Joined: Sun Jan 12, 2020 7:27 pm

Re: Wireguard Installation Problem

Post by DevinAK »

Still nothing.
User avatar
Joulinar
Posts: 5087
Joined: Sat Nov 16, 2019 12:49 am

Re: Wireguard Installation Problem

Post by Joulinar »

are you able to perform some network traffic collection on your router, to see what is happening and why thinks are not forwarded?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
DevinAK
Posts: 7
Joined: Sun Jan 12, 2020 7:27 pm

Re: Wireguard Installation Problem

Post by DevinAK »

I tried looking at the logs, but there is nothing there. I've started posting on Netgear forums as well for issues on port forwarding with my router.
User avatar
Joulinar
Posts: 5087
Joined: Sat Nov 16, 2019 12:49 am

Re: Wireguard Installation Problem

Post by Joulinar »

ok let' see what is coming back, at least how to discover/record the traffic
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
Caporeira
Posts: 18
Joined: Sat May 29, 2021 11:21 pm

Re: Wireguard Installation Problem

Post by Caporeira »

I have installed and configured Wireguard on my Rpi3.
Duck DNS is also configured.

I have generated confirm for client and import this configuration on my android phone.

On my router (Huawei B818) on Virtual Server I have forwarded Port 80, 22 and 51820 to DietPi.

When I'm connected over Wireguard I don't have internet on my phone and no connection to DietPi.

What can be the issue?
User avatar
Joulinar
Posts: 5087
Joined: Sat Nov 16, 2019 12:49 am

Re: Wireguard Installation Problem

Post by Joulinar »

Hi,

why did you forward 80 and 22? Especially 22 will open your system for SSH access to the internet. If possible something you should avoid. Some for 80. This will allow unencrypted HTTP access to a web server. If you plan to access a web server, I recommend to open 80+443, activate HTTPS and force a redirect on the web server from HTTP > HTTPS

on port 51820, do you forward TCP or UDP? because WireGuard VPN traffic is UDP.

Do you see any handshake on your WireGuard Server is you run wg command?
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
User avatar
trendy
Posts: 340
Joined: Tue Feb 25, 2020 2:54 pm

Re: Wireguard Installation Problem

Post by trendy »

You'll need to enable forwarding on the RPi as well as NAT outgoing traffic to the router. I presume that the configuration on the Android is set to forward everything already to the WG server.
Post Reply