Can't change webserver preference. Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
LeoNeeD
Posts: 2
Joined: Wed Jan 08, 2020 10:46 am

Can't change webserver preference.

Post by LeoNeeD »

Hi. I'm expecting some troubles after installing PiHole.

1. I'm installed PiHole and all worked fine.
2. After change from Wi-Fi dongle to Ethernet cable and executing

Code: Select all

pihole -r
my lighttpd service died and wont work after rebot. Tried some desicions from Google, but it doesn't help me.
3. Made

Code: Select all

apt-get purge lighttpd
and install Nginx from dietpi-software utility. Then Web panel of Pihole and my custom index.html became reachable.
4. From then i can't change Webserver Preference option in dietpi-software from lighttpd to Nginx. It says that preference is changed, but after relaunch of dietpi-software lighttpd still there.

How can i fianlly change it to Nginx.

Thanks in advance!
User avatar
Joulinar
Posts: 2584
Joined: Sat Nov 16, 2019 12:49 am

Re: Can't change webserver preference.

Post by Joulinar »

Hi,
can you rollback to lighttpd? and than we could check what the issues with lighttpd are.
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
LeoNeeD
Posts: 2
Joined: Wed Jan 08, 2020 10:46 am

Re: Can't change webserver preference.

Post by LeoNeeD »

I dont know what it was...

I deleted Nginx and again install Lighttpd from dietpi-software utility. And all works fine :D
Post Reply