Unable to install Emby server on Rpi

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
stum100

Unable to install Emby server on Rpi

Post by stum100 »

Hi all,

For some reason, I'm unable to install Emby server from the installation menu - it takes a long time going through the installation process, but eventually fails with an error 1000. Looking further into it, the installation fails due to unmet dependencies.

I'm attempting to set it up on a Rpi 256MB - I understand that transcoding will be a big no on this device, but I just want to use it to manage my media library on Kodi for multiple users. If anyone has been able to set-up this up, or has run into the same problem during installation and knows how to get around it, I'd love to know.

It would have been a good idea for me to grab the logs, unfortunately when I gave up trying to install Emby - I decided to set up the Rpi as a MySql server instead for my Kodi media library; while this works, I still think Emby would probably be a better option.

Just to add, after the failed installation, I did try the suggestions to fix the unmet dependencies but to no avail. Also, if anyone has a working SD image of Emby for Rpi they'd like to share, that would be fantastic.

Many thanks.
User avatar
Fourdee
Site Admin
Posts: 2782
Joined: Tue Feb 06, 2007 1:36 pm

Re: Unable to install Emby server on Rpi

Post by Fourdee »

Hi,

Looks like an issue with the Mono repo and packages we use during installation. Ive created a ticket for this, you can track the status here: https://github.com/Fourdee/DietPi/issues/534

We'll look into the issue, thanks for reporting :)
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: Unable to install Emby server on Rpi

Post by johnvick »

I've recently tried Emby on Pi3 and Bpi M1 - worked on both but it wasn't very stable - seemed to randomly stop.

On XU4 it works very well. I doubt you'd have much success with your Pi.

I've done MySQL for Kodi on all these devices and works well on all.

Having said that Emby is much nicer as back end database for Kodi.

John
Post Reply