Fresh Install failing to setup NFS

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
darkpollo
Posts: 3
Joined: Mon Dec 23, 2019 4:18 pm

Fresh Install failing to setup NFS

Post by darkpollo »

Hi,

First post here.
I have been playing with dietpi for awhile.
Today I installed a fresh new image on a PI2B with an 16GB card and I am trying to connect with my sinology using NFS.
I have another dietpi setup already connected with the sinology using NFS, so I am pretty sure the Sinology is not the issue here.
The problem I am having is that the drive manager, when trying to setup the first NFS connection, fails to install the "netbase".

Code: Select all

[ INFO ] DietPi-Drive_Manager | Checking for required APT packages: nfs-common netbase
[ INFO ] DietPi-Drive_Manager | Flagged for install: nfs-common
[ INFO ] DietPi-Drive_Manager | Flagged for install: netbase
[ INFO ] DietPi-Drive_Manager | APT update, please wait...
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 https://archive.raspberrypi.org/debian buster InRelease
Reading package lists...
And the error:

Code: Select all

DietPi-Drive_Manager: G_AGI nfs-common netbase
                                                             │  - Exit code: 100
                                                             │  - DietPi version: v6.26.3 (MichaIng/master) | HW_MODEL:2 | HW_ARCH:2 | DISTRO:5
                                                             │  - Image creator: DietPi Core Team
                                                             │  - Pre-image: Raspbian Lite
                                                             │
                                                             │ Log file content:
                                                             │ Selecting previously unselected package netbase.^M
                                                             │ (Reading database ... ^M(Reading database ... 5%^M(Reading database ... 10%^M(Reading
                                                             │ database ... 15%^M(Reading database ... 20%^M(Reading database ... 25%^M(Reading databas
                                                             │ ... 30%^M(Reading database ... 35%^M(Reading database ... 40%^M(Reading database ... 45%
                                                             │ (Reading database ... 50%^M(Reading database ... 55%^M(Reading database ... 60%^M(Readin
                                                             │ database ... 65%^Mdpkg: unrecoverable fatal error, aborting:^M
                                                             │  files list file for package 'raspberrypi-sys-mods' is missing final newline^M
Any ideas?
Thanks!
darkpollo
Posts: 3
Joined: Mon Dec 23, 2019 4:18 pm

Re: Fresh Install failing to setup NFS

Post by darkpollo »

Reply to myself in case it helps others.
It was a corrupted file.
So I downloaded the image again, flash it again with an updated etcher.io and then reinstall.
now everything works as expected.

:)
Post Reply