XU4 unable to upgrade

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
n8xyn
Posts: 26
Joined: Thu Apr 21, 2016 1:04 am

XU4 unable to upgrade

Post by n8xyn »

While attempting to upgrade to day I get

Get:1 http://oph.mdrjr.net/meveric/ jessie/backports libharfbuzz0b armhf 1.2.7-1~bpo8 [588 kB]
Get:2 https://dev2day.de/pms/ jessie/main plexmediaserver-installer armhf 1.1.4.2757-24ffd60-1~jessie [4,054 B]
Get:3 http://oph.mdrjr.net/meveric/ jessie/backports libharfbuzz-icu0 armhf 1.2.7-1~bpo8 [438 kB]
Fetched 1,030 kB in 1s (522 kB/s)
Setting up udev (215-17+deb8u5) ...
addgroup: The group `input' already exists as a system group. Exiting.
update-initramfs: deferring update (trigger activated)
insserv: warning: script 'fan.sh' missing LSB tags and overrides
insserv: There is a loop between service minidlna and fan.sh if stopped
insserv: loop involving service fan.sh at depth 2
insserv: loop involving service minidlna at depth 1
insserv: Stopping fan.sh depends on minidlna and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package udev (--configure):
subprocess installed post-installation script returned error exit status 1
Processing triggers for initramfs-tools (0.120+deb8u2) ...
ln: failed to create hard link ‘/boot/initrd.img-3.10.96+.dpkg-bak’ => ‘/boot/initrd.img-3.10.96+’: Operation not permitted
update-initramfs: Generating /boot/initrd.img-3.10.96+
Image Name: uInitrd
Created: Fri Sep 23 15:03:56 2016
Image Type: ARM Linux RAMDisk Image (uncompressed)
Data Size: 4027112 Bytes = 3932.73 kB = 3.84 MB
Load Address: 00000000
Entry Point: 00000000
Errors were encountered while processing:
udev
E: Sub-process /usr/bin/dpkg returned an error code (1)

Rebooted and still the same, any ideas?

Thanks.
luzifia
Posts: 48
Joined: Tue Jun 28, 2016 9:48 am

Re: XU4 unable to upgrade

Post by luzifia »

hi There,
yes I have the same Problem, and done some tryouts.

http://dietpi.com/phpbb/viewtopic.php?f=11&t=689

In This case I'm a Little lucky because I have 2 Systems. One active and one Testsystem. So I have had V130 an my testsystem - now this is my active one. Fourdee already have a look at this.

I've read your Error an I can reproduce this also.

We should concentrate this xu4 Problem in one Thread. Maybe easier for the Dietpi-Developers to find all XU4 Errors in one Thread.

So if you have an Image From V130 I recommend you use this. Unfortunately I don't know a way to break the Installation Routine @V130 witch is the last running on xu4 as far as i know. My Image is 64GB. so it's very hard to transfer it. Sorry for this bad News.

Greets
Luzi
n8xyn
Posts: 26
Joined: Thu Apr 21, 2016 1:04 am

Re: XU4 unable to upgrade

Post by n8xyn »

Fortunately I do have a backup from 9/02 I was trying to avoid restoring it but as a last resort I will. The machine is still functioning in it's roll as a Plex server so I might just let it be for the present. I have another XU4 but it's running Odroid's Ubuntu 16.04 LTS image. Thanks.
luzifia
Posts: 48
Joined: Tue Jun 28, 2016 9:48 am

Re: XU4 unable to upgrade

Post by luzifia »

so we can try something if u want.

i have uploaded my Image to we Transfer (https://www.wetransfer.com/downloads/d3 ... 420/f978c2) for download ... i compess it with rar.
if u extract it u can use it.
This link is only one week online

but there are also some small Problems.

you'll Need a Keyboard and a hdmi Display or TV. your System have a diffrent MAC Adress so you have no Network Connection.

run dietpi-config an reinit the eth0 Interface to dhcp
reboot
then
apt-get update
apt-get upgrade
apt-get dist-upgrade

DO NOT USE dietpi-update

correct your fstab ... there is mine in there

sudo nano /etc/fstab to your USB drives.

after that you have to define the Location of the plex lib (may you take a backup before - copy the orig Library Directory to another location)

you'll find it

/etc/default
sudo nano /etc/default/plexmediaserver

there you'll find
PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR=

remove "#" this sign in fron of the line to make it active

i hope this help u

greets
luzi
n8xyn
Posts: 26
Joined: Thu Apr 21, 2016 1:04 am

Re: XU4 unable to upgrade

Post by n8xyn »

Ok, I restored from an image file created on 9/2/16 and all was well until I took the updates by doing

apt-get update
apt-get upgrade

Now it's back to the same error :-)
n8xyn
Posts: 26
Joined: Thu Apr 21, 2016 1:04 am

Re: XU4 unable to upgrade

Post by n8xyn »

Dont know enough to have thought about it, but that worked, thanks very much sir :-)
Post Reply