V131 XU4

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
luzifia
Posts: 48
Joined: Tue Jun 28, 2016 9:48 am

V131 XU4

Post by luzifia »

Hi Friends.

XU4 upgrade from v130 -> V131

Sofware

Plexmediaserver - Plex Database was on USB_1 (i haven't connected this hdd again so i hope i can reuse my plex database)
Transmission
MC
SAMBA Client
4 USB HDD per Hub on USB3.0
Cloudshell

After upgrade:
-> No USB Drive available anymore
-> cannot list Directory in mnt (sudo blkid works)
-> cannot run dietpi-drive_manager
-> cannot rund dietpi-Software

so: new testinstallation on my second xu4
everything installed i needed without the usb drives. after that "shutdown now" - take the Hardware in my "Server"-room. ... now the new fresh System does not boot anymore ... i've done this 3 times before i write this thread.

so the last update killed my System total and i cannot install a stable, rebootable System on my xu4. "reboot" works ... "shutdown now" and restart not (!)

or is ist possible, that i stop the update function at fresh install at v130 or go back from v131 to v130. are there some backups from my older files eg. /etc/fstab (old USB Mount config?)

please help.

nice greetings
luzi
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: V131 XU4

Post by Fourdee »

4 USB HDD per Hub on USB3.0
Hi,

We switched usb drive mounting to auto filesystem in SystemD, for v131. A custom, or unexpected fstab entry may prevent the patch from being applied correctly.
We will need to convert your 4 USB drives to the new system.

We need to check your system configuration. Please send a bug report:
http://dietpi.com/phpbb/viewtopic.php?f=8&t=499#p2184

No need to fill the form out, please reply with the reference code and i'll look into the issue and get this resolved for you.

If you can remember which drive was mounted to which location, this would also help.

Please also run the following program, and take a screenshot:

Code: Select all

dietpi-drive_manager
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
luzifia
Posts: 48
Joined: Tue Jun 28, 2016 9:48 am

Re: V131 XU4

Post by luzifia »

hi
thanks 4 fast answer

so ... 1st i have to fix the Problem, that i cannot boot the xu4 after "shutdown now"
for this case i think i have 2 ways to go:
a) fresh install and prevent the Problem so i can shutdown the xu4 an reboot again.
or
b) the broken System make bootable ... after that, i can follow your instuctions.

then i can try to connect an empty usb hdd for test to xu4.

i told before: that this is not possible to boot after shutdown. so for this Problem i Need a solution - please.

thanks
luzi
luzifia
Posts: 48
Joined: Tue Jun 28, 2016 9:48 am

Re: V131 XU4

Post by luzifia »

i ve done your instruction before i've done shutdown now.

reference Code from report
0fb2c82e-b551-405c-bd8c-ac6e71210dd8-0
there is no plex or Transmission .... only update an some Basics

after that ... shutdown now ... same result as before

nice greetings
luzi
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: V131 XU4

Post by Fourdee »

luzifia wrote:i ve done your instruction before i've done shutdown now.

reference Code from report
0fb2c82e-b551-405c-bd8c-ac6e71210dd8-0
there is no plex or Transmission .... only update an some Basics

after that ... shutdown now ... same result as before

nice greetings
luzi
Hi Luzi,

Thanks for sending the report. Although missing your 4 USB drive mounts, /etc/fstab looks fine.

Long story short, a reinstall will fix the issue. However, I'll take a look over your configs in the next few days and report back.

As your system was manually configured outside of the DietPi programs, my suggestion at the moment would be to:
- Reinstall DietPi
- Setup the software you need, and use DietPi-Drive_Manager to setup the mounts (with UUID).
- Once your system is "final", run DietPi-Backup and create a backup.
- Should anything go wrong in the future, a simple restore of your backup will revert your system back to the previous state.
> cannot run dietpi-drive_manager
-> cannot rund dietpi-Software
Do you receive any errors when attempting to run these programs?
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
luzifia
Posts: 48
Joined: Tue Jun 28, 2016 9:48 am

Re: V131 XU4

Post by luzifia »

hello friends,
it was not possible for me to get the xu4 run on V131.
so i have restored one v130 Image on my testsystem-repatched plex to last Version. (apt-get update, apt-get upgrade, apt-get dist-upgrade; but not dietpi-update)
V131 did not work for me on my xu4's.

so, if anyone of the developers want some Information about my running System on v130 don't hesitate to ask me.
i like dietpi very much and i hope i can help to fix this strange Situation.

all 4 hdd and the plex lib is ok. - thank u Dietpi-IT-God :D

my testsystem is now my activ one. so the other one is ready again for a clean install. so please give some instructions to catch this bug :)

i can reproduce all ... i have enough other smaller ~2TB USB HDD to recreate the Situation.

@Fourdee:
no, i did not get any error Messages running this programs.
i was connected via shh (putty) on the System and as i want to run one of this programms, only the Cursor was on the Screen flashing an i thought it was laughing to me :D

yes, u miss this 4 hdd because i did not connect it ... my media lib is 4 x 6TB and i'm not brave enough to take this risk.

at first i take a bugreport again from my running V130 System.
The reference code: 3b141ce3-e68d-4773-9c52-2303eb248ede-0

Now I reinstall Kodisystem for my daughter an re-link it to plex. after that - in few hours when resync is done (plexkodiconnect) i take the testsystem an reproduce this again on testsystem. if u have any other intructions, i'll reread this thread before i start.

is it possible to send you a private message ... may i have some intressting for u, but not for public.

greets
luzi.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: V131 XU4

Post by Fourdee »

so, if anyone of the developers want some Information about my running System on v130 don't hesitate to ask me.
i like dietpi very much and i hope i can help to fix this strange Situation.
at first i take a bugreport again from my running V130 System.
The reference code: 3b141ce3-e68d-4773-9c52-2303eb248ede-0
Excellent, this will contain your /etc/fstab config, which i'am keen to check. Hopefully see what went wrong. I'll take a look and report back.
is it possible to send you a private message ... may i have some intressting for u, but not for public.
Forum messages are disabled. Please use my email address daniel.knight@dietpi.com
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: V131 XU4

Post by Fourdee »

Ok, I think we can try something to get your v130 updated.

Try the following on your v130 system:
- Backup your system, either with dietpi-backup (using location /mnt/dietpi-backup) or save an image.
- Run dietpi-update
- Before rebooting, copy and paste the following into terminal/SSH (it contains your UUID's for external drives, using the new system):

Code: Select all

cat << _EOF_ > /etc/fstab
#Internal Drives---------------------------------------------------
proc            /proc           proc    defaults											0 0
/dev/mmcblk0p1  /boot           auto    defaults,noatime,discard							0 2
/dev/mmcblk0p2  /               auto    defaults,noatime,discard							0 1
tmpfs 			/tmp  			tmpfs 	defaults,noatime,nodev,nosuid,mode=1777				0 0
tmpfs 			/var/log 		tmpfs 	defaults,size=20m,noatime,nodev,nosuid,mode=1777	0 0
tmpfs 			/DietPi 		tmpfs 	defaults,size=10m,noatime,nodev,nosuid,mode=1777	0 0

#External Drives---------------------------------------------------
#NB: Please use dietpi-drive_manager to setup and control your external drives.
UUID="86b8d807-340f-4873-8937-acd62adc4c2f" /mnt/usb_1 auto     defaults,noatime,nofail,x-systemd.automount  0       0
UUID="7b004310-3ce4-4ab1-9bd2-7889b4c4aa7b" /mnt/usb_2 auto     defaults,noatime,nofail,x-systemd.automount  0       0
UUID="cf58423f-08d8-425e-a554-cd2d5190c7af" /mnt/usb_3 auto     defaults,noatime,nofail,x-systemd.automount  0       0
UUID="3ae3ad10-05ec-4dd0-8608-68facd31268a" /mnt/usb_4 auto     defaults,noatime,nofail,x-systemd.automount  0       0
#/dev/sde1       							/mnt/usb_5 auto     defaults,noatime,nofail,x-systemd.automount  0       0

#Samba Client------------------------------------------------------
#/mnt/samba . Please use dietpi-config and the Networking Options: NAS menu to setup this mount

#FTP Client Mount--------------------------------------------------
#/mnt/ftp_client . Please use dietpi-config and the Networking Options: NAS menu to setup this mount

#NFS Client Mount--------------------------------------------------
#/mnt/nfs_client . Please use dietpi-config and the Networking Options: NAS menu to setup this mount
_EOF_
- Reboot system
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
luzifia
Posts: 48
Joined: Tue Jun 28, 2016 9:48 am

Re: V131 XU4

Post by luzifia »

Hi,
i've got an error on my coudshellscreen
CopyRAMError
CopyRAMError
and the xu4 did not came out of this ... i think this is the Problem ... not the drive Manager

may u haven an idea.

greets
luzi

PS: I think same Problem http://dietpi.com/phpbb/viewtopic.php?f=11&t=695
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: V131 XU4

Post by Fourdee »

luzifia wrote:Hi,
i've got an error on my coudshellscreen
If this occurs again, plug in a keyboard and press CTRL+C.

Then type:

Code: Select all

df -h | grep DietPi
You should get:

Code: Select all

root@DietPi:~# df -h | grep DietPi
tmpfs            10M  1.2M  8.9M  12% /DietPi
And if you get a chance:

Code: Select all

ls -lha / | grep DietPi
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply