Nextcloud & Letsencrypt - https:// notworking

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
i_max
Posts: 2
Joined: Mon Nov 25, 2019 10:35 am

Nextcloud & Letsencrypt - https:// notworking

Post by i_max »

Hi,

I tried to setup my raspberry pi as an Nextcloud server. On a fresh dietpi install I install Nextcloud and then certbot. Installations did not return any errors. Access of Nextcloud via http and my dyndns adress works fine. Both ports 80 and 443 are being forwarded from my router. When I do a portscan however I get the results that port 80 is open and port 443 blocked. So far this is the only thing I found which seems wrong to me.
I would be gratefull for any tipps where I should be looking for any errors.

Thanks, Max
User avatar
MichaIng
Site Admin
Posts: 2293
Joined: Sat Nov 18, 2017 6:21 pm

Re: Nextcloud & Letsencrypt - https:// notworking

Post by MichaIng »

Did you run dietpi-letsencrypt after installing CertBot? This install itself does not configure HTTPS, for this run the mentioned command and enter additional info, for have the webserver configured accordingly.
i_max
Posts: 2
Joined: Mon Nov 25, 2019 10:35 am

Re: Nextcloud & Letsencrypt - https:// notworking

Post by i_max »

Yes, I ran dietpi-letsencrypt after the installation of certbot. I tried a couple of other things to configure lighttpd, but unfortunately I did not get it to work.
I did a fresh install of dietpi, nextcloud, LEMP, redis and certbot this morning. I worked right out of the box (same configuration for letsencrypt as for lighttpd) and so far everything is working fine.

Thank you for your help!

Max
Post Reply