Pine64 / V 130 v131 / Serial Port wrong permissions /ttyUSB0 Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
maxtox

Pine64 / V 130 v131 / Serial Port wrong permissions /ttyUSB0

Post by maxtox »

Hi,

i am using dietPi with Pine 64 and Raspi 2B.

Arduino is connected to raspi /Pine 64 and write/receive data.

Problem i have is, that everything is fine with Raspi, but Pine does have 660 permission.

If i change it to 666 and use it as root, it starting to work for couple seconds and i get Error serial port ttyUSB0 is not open, unable to write.!

when i install debian ->standard image, serial is it starting to work fine..

BUT

I Love DietPi!!!! I want to use it as Image for this Homeautomation Project = ioBROKER, which can be used for everything (sonos, mysesnsors, hue etc..)

Could you HELP PLEASE
maxtox

Re: Pine64 / V 130 v131 / Serial Port wrong permissions /tty

Post by maxtox »

No solution? I would REALY love to use dietpi @pine64!
maxtox

Re: Pine64 / V 130 v131 / Serial Port wrong permissions /tty

Post by maxtox »

HI...

could you please at least tell me if you will work on this or not? Because i have to decide which image to take for ioBroker.net project!
pfeerick

Re: Pine64 / V 130 v131 / Serial Port wrong permissions /tty

Post by pfeerick »

Can you give some more information on your setup? Are you trying this from a different user account than root? If so, what group permissions have you given that user (i.e. is it a member of the dialout group?) Is it only write that is being affected or read also? How are you trying to connect to the Arduino/RPi? I grabbed a Arduino, loaded on some code that prints out the ASCII table every 10 seconds, and plugged that into the pine64 running dietpi. I was able to connect to it using screen (screen /dev/ttyUSB0 9600) and see the output from the Arduino without any issue, when logged in as the root user.

btw, I am on the pine64 forum normally, but missed this one, and thought I'd reply here (instead of re-open the topic) as you hadn't gotten any replies at all!
maxtox

Re: Pine64 / V 130 v131 / Serial Port wrong permissions /tty

Post by maxtox »

Hi....

To be honest, I nearly dropped dietpi this morning by the post on pine64 forum...

BUT THANK YOU FOR ANSWERING!

I was root user and unable to write.

After reinstalling from scratch v132... No help
Installing 133 this morning WORKS!

So thank you.. I will post if it'll change!

Thank you!

P. S. :can you add a routine for home automation system iobroker.net? I would point admin of iobroker to you if you could!
pfeerick

Re: Pine64 / V 130 v131 / Serial Port wrong permissions /tty

Post by pfeerick »

Hm... very curious... I just had a quick look over the changes from v132 -v133 and nothing is jumping out as a fix or even a related change, but if it is now working, it doesn't really matter! (although it would be nice to know what it was, in case it goes wrong again! :-D).

No, that would be Fourdee (Dan). You can add an issue to the issue tracker requesting the addition of ioBroker, and see what his response is. You'll see the format when you look - I see someone recently requested Home Assistant to be added.
maxtox

Re: Pine64 / V 130 v131 / Serial Port wrong permissions /tty

Post by maxtox »

hi...it started again!!!

can we do it somehow over teamviewer? how can i contact you? Send me email to <myusername>@gmx.de
Post Reply