"Cannot currently show the desktop" msg in VNC

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
sfh1975
Posts: 4
Joined: Sun Nov 03, 2019 12:22 pm

"Cannot currently show the desktop" msg in VNC

Post by sfh1975 »

Hi everyone, can someone help?
Much appreciated.

root@DietPi:~# cat /var/log/Xorg.0.log
[ 82007.382]
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[ 82007.382] Build Operating System: Linux 4.15.0-48-generic armv8l Raspbian
[ 82007.382] Current Operating System: Linux DietPi 4.19.75-v7l+ #1270 SMP Tue Sep 24 18:51:41 BST 2019 armv7l
[ 82007.382] Kernel command line: coherent_pool=1M 8250.nr_uarts=1 cma=64M cma=256M smsc95xx.macaddr=DC:A6:32:2E:CC:97 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000 dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty1 root=PARTUUID=cb7b86f7-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
[ 82007.383] Build Date: 05 June 2019 12:49:54PM
[ 82007.383] xorg-server 2:1.20.4-1+rpt1 (https://www.debian.org/support)
[ 82007.383] Current version of pixman: 0.36.0
[ 82007.383] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 82007.383] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 82007.383] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Nov 3 22:18:00 2019
[ 82007.385] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 82007.385] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 82007.390] (==) ServerLayout "ServerLayout0"
[ 82007.390] (==) No screen section available. Using defaults.
[ 82007.390] (**) |-->Screen "Default Screen Section" (0)
[ 82007.390] (**) | |-->Monitor "<default monitor>"
[ 82007.395] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 82007.395] (**) Option "BlankTime" "0"
[ 82007.396] (**) Option "StandbyTime" "0"
[ 82007.396] (**) Option "SuspendTime" "0"
[ 82007.396] (**) Option "OffTime" "0"
[ 82007.396] (==) Automatically adding devices
[ 82007.396] (==) Automatically enabling devices
[ 82007.396] (==) Automatically adding GPU devices
[ 82007.396] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 82007.396] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 82007.396] Entry deleted from font path.
[ 82007.396] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[ 82007.396] Entry deleted from font path.
[ 82007.396] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[ 82007.396] Entry deleted from font path.
[ 82007.396] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
[ 82007.396] Entry deleted from font path.
[ 82007.396] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[ 82007.396] Entry deleted from font path.
[ 82007.396] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[ 82007.396] Entry deleted from font path.
[ 82007.397] (==) FontPath set to:
/usr/share/fonts/X11/misc,
built-ins
[ 82007.397] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 82007.397] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 82007.397] (II) Loader magic: 0x1fcf80
[ 82007.397] (II) Module ABI versions:
[ 82007.397] X.Org ANSI C Emulation: 0.4
[ 82007.397] X.Org Video Driver: 24.0
[ 82007.397] X.Org XInput driver : 24.1
[ 82007.397] X.Org Server Extension : 10.0
[ 82007.400] (--) using VT number 2

[ 82007.400] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[ 82007.403] (II) xfree86: Adding drm device (/dev/dri/card1)
[ 82007.404] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 82007.406] (II) no primary bus or device found
[ 82007.406] falling back to /sys/devices/platform/soc/soc:gpu/drm/card1
[ 82007.406] (II) LoadModule: "glx"
[ 82007.407] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 82007.467] (II) Module glx: vendor="X.Org Foundation"
[ 82007.467] compiled for 1.20.4, module version = 1.0.0
[ 82007.467] ABI class: X.Org Server Extension, version 10.0
[ 82007.467] (==) Matched modesetting as autoconfigured driver 0
[ 82007.467] (==) Matched fbdev as autoconfigured driver 1
[ 82007.467] (==) Assigned the driver to the xf86ConfigLayout
[ 82007.467] (II) LoadModule: "modesetting"
[ 82007.467] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 82007.472] (II) Module modesetting: vendor="X.Org Foundation"
[ 82007.472] compiled for 1.20.4, module version = 1.20.4
[ 82007.472] Module class: X.Org Video Driver
[ 82007.472] ABI class: X.Org Video Driver, version 24.0
[ 82007.472] (II) LoadModule: "fbdev"
[ 82007.472] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 82007.474] (II) Module fbdev: vendor="X.Org Foundation"
[ 82007.474] compiled for 1.20.3, module version = 0.5.0
[ 82007.474] Module class: X.Org Video Driver
[ 82007.474] ABI class: X.Org Video Driver, version 24.0
[ 82007.474] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 82007.474] (II) FBDEV: driver for framebuffer: fbdev
[ 82007.475] (II) modeset(0): using drv /dev/dri/card1
[ 82007.475] (WW) Falling back to old probe method for fbdev
[ 82007.475] (II) Loading sub module "fbdevhw"
[ 82007.475] (II) LoadModule: "fbdevhw"
[ 82007.476] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 82007.478] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 82007.478] compiled for 1.20.4, module version = 0.0.2
[ 82007.478] ABI class: X.Org Video Driver, version 24.0
[ 82007.478] (EE) open /dev/fb0: No such file or directory
[ 82007.480] (II) modeset(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 82007.481] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[ 82007.481] (==) modeset(0): RGB weight 888
[ 82007.481] (==) modeset(0): Default visual is TrueColor
[ 82007.481] (II) Loading sub module "glamoregl"
[ 82007.481] (II) LoadModule: "glamoregl"
[ 82007.482] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[ 82007.537] (II) Module glamoregl: vendor="X.Org Foundation"
[ 82007.537] compiled for 1.20.4, module version = 1.0.1
[ 82007.537] ABI class: X.Org ANSI C Emulation, version 0.4
[ 82008.427] (II) modeset(0): glamor X acceleration enabled on V3D 4.2
[ 82008.427] (II) modeset(0): glamor initialized
[ 82008.427] (WW) modeset(0): No outputs definitely connected, trying again...
[ 82008.427] (WW) modeset(0): Unable to find connected outputs - setting 1024x768 initial framebuffer
[ 82008.427] (==) modeset(0): Using gamma correction (1.0, 1.0, 1.0)
[ 82008.427] (EE) modeset(0): No modes.
[ 82008.432] (II) UnloadModule: "modesetting"
[ 82008.432] (II) UnloadSubModule: "glamoregl"
[ 82008.432] (II) Unloading glamoregl
[ 82008.432] (EE) Screen(s) found, but none have a usable configuration.
[ 82008.432] (EE)
Fatal server error:
[ 82008.432] (EE) no screens found(EE)
[ 82008.433] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 82008.433] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 82008.433] (EE)
[ 82008.433] (EE) Server terminated with error (1). Closing log file.
sfh1975
Posts: 4
Joined: Sun Nov 03, 2019 12:22 pm

Re: "Cannot currently show the desktop" msg in VNC

Post by sfh1975 »

Anyone? :(
caic
Posts: 1
Joined: Wed Dec 04, 2019 12:51 pm

Re: "Cannot currently show the desktop" msg in VNC

Post by caic »

Hi,

Same problem here: I couldn't get my rpi4 headless desktop via VNC.

In Raspbian this could be solved selecting a resolution in config tool but this is not working in DietPi.

I set this param in /DietPi/config.txt and it solved my problem:

Code: Select all

hdmi_safe=1
Cheers!
Post Reply