Letsencrypt not working anymore

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Tresi
Posts: 5
Joined: Mon May 13, 2019 8:02 am

Letsencrypt not working anymore

Post by Tresi »

Hi,

Letsencrypt is not working anymore since many weeks. I didn't have the time to look after this problem. It was running for months without any problems and I didn't change anything. My hope was after applying a new update and a reboot all is working like before but unfortunately it doesn't. I am using Dietpi 6.26(?) which was shown as latest update and I use a Raspberry Pi 2.

In my router ports 80 and 443 are forwarded to the IP address of the Raspberry in my local network and I have a dynamic DNS entry that has the correct A/AAAA entries with my current IP address. But if I try to renew with dietpi-letsencrypt or certbot I am getting the following errors:

Code: Select all

$ sudo certbot renew
Saving debug log to /var/log/letsencrypt/letsencrypt.log

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Processing /etc/letsencrypt/renewal/xyz.dns.org.conf
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Cert is due for renewal, auto-renewing...
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for xyz.dns.org
Waiting for verification...
Cleaning up challenges
Attempting to renew cert (xyz.dns.org) from /etc/letsencrypt/renewal/xyz.dns.org.conf produced an unexpected error: Failed authorization procedure. xyz.dns.org (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://xyz.dns.org/.well-known/acme-challenge/btiAcexPDwNV8qv-HApz7R1ONB0fwm1TkbikhghHBgM: Connection refused. Skipping.
All renewal attempts failed. The following certs could not be renewed:
  /etc/letsencrypt/live/xyz.dns.org/fullchain.pem (failure)

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

All renewal attempts failed. The following certs could not be renewed:
  /etc/letsencrypt/live/xyz.dns.org/fullchain.pem (failure)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1 renew failure(s), 0 parse failure(s)

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: xyz.dns.org
   Type:   connection
   Detail: Fetching
   http://xyz.dns.org/.well-known/acme-challenge/btiAcexPDwNV8qv-HApz7R1ONB0fwm1TkbikhghHBgM:
   Connection refused

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address. Additionally, please check that
   your computer has a publicly routable IP address and that no
   firewalls are preventing the server from communicating with the
   client. If you're using the webroot plugin, you should also verify
   that you are serving files from the webroot path you provided.
If I try manually to call http://xyz.dns.org/.well-known/acme-cha ... bikhghHBgM I get an status code of 403 forbidden. Therefore I tried to change the owner of /etc/letsencrypt with all subfolders and files to www-data but this did not work.

Can anyone help me, please? I cannot use my Nextcloud instance any more and all my tasks, addresses, dates, notes and so on are in there.

If more information is needed, please tell me.

Thanks a lot in advance.

Kind regards,
tresi
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: Letsencrypt not working anymore

Post by johnvick »

what happens with

# certbot -d xyz.dns.org

?
Tresi
Posts: 5
Joined: Mon May 13, 2019 8:02 am

Re: Letsencrypt not working anymore

Post by Tresi »

Code: Select all

sudo certbot -d xyz.dns.org
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Certbot doesn't know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run "certbot certonly" to do so. You'll need to manually configure your web server to use the resulting certificate.
/var/log/letsencrypt/letsencrypt.log is empty
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: Letsencrypt not working anymore

Post by johnvick »

DId you try certbot certonly?

If you haven't already looked you may find the answer in the certbot forum.
Post Reply