WiFi hotspot slow

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
huzyzu
Posts: 1
Joined: Fri Oct 25, 2019 9:27 am

WiFi hotspot slow

Post by huzyzu »

Hi,

I use already for some time a raspberry pi 3 as a VPN router using dietpi with WiFi hotspot installed. All fine since some time ago, when the clients connected to the WiFi got disconnected and only a reboot could help. I also experienced that when a second device started to use the wifi, all devices got disconnected.

Because I did not find the problem, I have installed dietpi again on the raspberry pi 3, but I couldn't get the Wifi hotspot to work. It shows enabled, but I couldn't find the SSID on my phone.

Next step was to try a Odroid C2 with a USB Wifi Dongle (TP Link WN722N). Here the WiFi hotspot works, but only with slow speeds. I installed speedtest-cli and I get 26 Mb download on the Odroid, but while using the WiFi hotspot with the speed test speedtestfast.com, I get only 3 Mb download.

My best guess is that with one of the last updates of dietpi something changed in the settings for the WiFi Hotspot, but my knowledge on linux is limited, so I dont know where to start looking. I would expect that the WiFi hotspot would have similar speed as the odroid c2.

Big thanks for any help.
Last edited by huzyzu on Tue Nov 05, 2019 5:10 am, edited 1 time in total.
User avatar
MichaIng
Site Admin
Posts: 2295
Joined: Sat Nov 18, 2017 6:21 pm

Re: WiFi hotspot slow

Post by MichaIng »

Please do not rely on speedtest-cli, there are versions that shows wrong speed, see: viewtopic.php?f=11&t=6560

v6.26 did not contain some changes for the WiFi Hotspot. Note that not all WiFi dongles support AP mode, or they vary in performance/quality for that. To be sure it is an OS/config related issue, try to use exactly the same dongle that works well on Odroid, on RPi as well.

And please check dmesg and journalctl if there are any errors reported, the first kernel/driver related, the second command additionally can show software related messages-
Post Reply