Very old DietPi

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
ianboag
Posts: 1
Joined: Thu Oct 17, 2019 3:06 am

Very old DietPi

Post by ianboag »

I have some systems (happily) running V1.06. One of the other apps I run on it has fallen off the end of OpenSSL. Is there any way I can upgrade the DiPi to something newer where apt-get upgrade will work? The alternative (rebuilding the thing from scratch is a bit awful. I put it together a couple of years ago ... documentation is a bit thin :-(
User avatar
MichaIng
Site Admin
Posts: 2293
Joined: Sat Nov 18, 2017 6:21 pm

Re: Very old DietPi

Post by MichaIng »

@ianboag
Sorry, from my end you must flash a new image. All versions below 160/6.0 cannot be upgraded the official way and THAT old versions will 100% ship follow-up errors. The first knockout argument most likely is already the base Debian version which is not supported anymore, I guess it is Wheezy in your case? You need Stretch at least, Buster at best (current stable Debian) for current DietPi version, which means 2-3 major Debian version jumps, which will cause a LOT of tinkering to even go through the process and much more to get it run half-nicely ;).

Excuse my probably hard words, but I better want to be clear here, since really, trying to upgrade the system will cause you much more trouble and consumes much more time after all than simply starting from scratch and doing a nice clean documentation (or directly write scripts) about what you are doing :).
Post Reply