CPU Frequency not idling

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
lieferant
Posts: 2
Joined: Thu Oct 10, 2019 2:52 pm

CPU Frequency not idling

Post by lieferant » Thu Oct 10, 2019 2:57 pm

I have a brand new RPi 4 (4GB) and tried it with the latest stable version of Raspbian and the latest version of DietPi.

I set up netdata on both and I set max cpu frequency to 2000 (governor ondemand).

This is what I got:

DietPi
Screenshot 2019-10-10 at 15.49.43.png

Raspbian
Screenshot 2019-10-10 at 15.15.43.png
With Dietpi the CPU frequency is jumping around like crazy, while Raspbian idles at 600mhz as it is supposed to.
Why is that? Whats going wrong on Dietpi? What can I do?

Thanks a lot!

User avatar
WarHawk
Posts: 525
Joined: Thu Jul 20, 2017 7:55 am

Re: CPU Frequency not idling

Post by WarHawk » Fri Oct 11, 2019 4:03 am

Ondemand means frequency from lowest to max if it ever needs it

I usually edit the /etc/defaults/cpufrequtils from ondemand to conservative

This way it ramps up and down rather than go from 0 to 100 then back down to 0...just remember IO reads/writes are also tied to cpu frequency

lieferant
Posts: 2
Joined: Thu Oct 10, 2019 2:52 pm

Re: CPU Frequency not idling

Post by lieferant » Fri Oct 11, 2019 11:19 am

but why do DietPi and Raspbian behave that differently when both use the same settings?

User avatar
MichaIng
Site Admin
Posts: 1728
Joined: Sat Nov 18, 2017 5:21 pm

Re: CPU Frequency not idling

Post by MichaIng » Fri Oct 11, 2019 1:15 pm

It probably is the high default throttle down factor of DietPi or the low throttle up percentage. Please try to set the throttle down to 1 via dietpi-config which is default on RPi/Linux. We set it to 80 (40 since v6.26 when released) to not have the CPU freq down so fast after activity. Also raising throttle up percentage (from 50 default) to e.g. 85 or 95 might reduce the need to throttle up at all when e.g. Netdata itself takes > 50 but < 85/95% CPU usage for reading stats and updating graph. AFAIK 95 is default on RPi/Linux.

Will check later, there are files in /sys where you can check how often CPU governor changed frequency and most importantly how much time it was in which freq state. Probably we can/need to tune our default ondemand governor settings.

Post Reply