Spammer active on forum?

Having issues with your DietPi installation, or, found a bug? Post it here.
User avatar
MichaIng
Site Admin
Posts: 2423
Joined: Sat Nov 18, 2017 6:21 pm

Re: Spammer active on forum?

Post by MichaIng »

Some still slipping through, especially during Stop Forum Spam server downtimes, which occur somehow quite often (check logs). I think we indeed need block registers, in that case. Info should be announced/sticky in forum, also would be good to know how the registration page looks like if it is blocked due to SFS downtime. Sadly hard to check via test registers ;).

I do not feel any difference otherwise after disabling Q&A CAPTCHA, so this can stay and make registers much easier for regular users.
User avatar
MichaIng
Site Admin
Posts: 2423
Joined: Sat Nov 18, 2017 6:21 pm

Re: Spammer active on forum?

Post by MichaIng »

Still experimenting, since spammers still slipping through, although not much:

I re-enabled CAPTCHA, but reCAPTCHA this time. I noticed that the simple amount of registration attempts raised by ~ factor 4, after I disabled Q&A CAPTCHA. Makes sense since registration attempts failing on CAPTCHA are simply not logged. So our previous Q&A CAPTCHA was not ineffective, but only effective against ~80% of spam bots. While StopForumSpam does a VERY good job, with that high registration rate, here and there a spammer slips through. Lets see how well reCAPTCHA performs. Although I am no fans of sending any data to this provider, at least users will know it as being used very widely, they are updating it constantly and Fourdee already registered for a key some time ago ;).

Additionally I registered at StopForumSpam to have Ban Hammer reporting to their database and supporting the whole system. This means @johnvick @WarHawk:
Always use Ban Hammer to ban spammers and have all their posts and data (signature, avatar, attachments, ...) purged all together and have it reported to the StopForumSpam database.

Jep, reCAPTCHA is indeed quite effective, when watching the StopForumSpam trigger logs:

Code: Select all

29 Oct 2019 14:11
<---- Enabled reCAPTCHA
29 Oct 2019 12:05
29 Oct 2019 11:49
29 Oct 2019 11:40
29 Oct 2019 11:06
29 Oct 2019 10:49
29 Oct 2019 10:28
29 Oct 2019 10:18
29 Oct 2019 10:18
29 Oct 2019 09:41
29 Oct 2019 09:20
29 Oct 2019 09:14
29 Oct 2019 09:13
29 Oct 2019 09:07
29 Oct 2019 08:49
29 Oct 2019 08:38
29 Oct 2019 08:11
29 Oct 2019 08:06
29 Oct 2019 07:48
29 Oct 2019 07:45
29 Oct 2019 07:24
29 Oct 2019 07:19
29 Oct 2019 06:55
29 Oct 2019 06:42
29 Oct 2019 04:35
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: Spammer active on forum?

Post by johnvick »

Nice work thanks.
User avatar
WarHawk
Posts: 634
Joined: Thu Jul 20, 2017 8:55 am

Re: Spammer active on forum?

Post by WarHawk »

MichaIng wrote: Tue Oct 29, 2019 1:29 pm
Additionally I registered at StopForumSpam to have Ban Hammer reporting to their database and supporting the whole system. This means @johnvick @WarHawk:
Always use Ban Hammer to ban spammers and have all their posts and data (signature, avatar, attachments, ...) purged all together and have it reported to the StopForumSpam database.

Roger that!
User avatar
MichaIng
Site Admin
Posts: 2423
Joined: Sat Nov 18, 2017 6:21 pm

Re: Spammer active on forum?

Post by MichaIng »

Still many spammers slipping through. Its like "they" need some hours to know which CAPTCHA we use, then are able to crack it. SFS does its job, but there are now several registers which have less then 5 entries in their database (for either mail, IP or username), hence SFS does not trigger. The ones I checked have now 5 or more entries with our block+report ;). I reduced the required entries to 3, however this raises the chance for false blocks of course.

@erpl
I saw you needed three register attempts to finally get through SFS filter? Since I never saw this block page, was it at least clear about what to do/try? From what I could derive from the logs, your mail address must have been the issue, but having a look into the SFS database I could not find a single entry, so I am confused why it triggered. Or did you do some step to get it removed there meanwhile?
erpl
Posts: 3
Joined: Wed Nov 06, 2019 9:54 am

Re: Spammer active on forum?

Post by erpl »

Hi,
I tried several emails. First some temp ones, so I didn't think twice about being blocked. Red message just says
No soup for you! Your address was flagged as spam
, or something of the sort.
Then tried with a first non-temporary email, but that one didn't work either. Just in case of bad cookies, I cleaned my browser history, and was finally able to sign in with another address.
I might have been tunnelling through Tor on the first attempts, pretty sure that didn't help...

P.S. I am a Nigerian prince looking to transfer funds ... I'm joking.
Post Reply