Rpi Hotspot

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
bricolodu13
Posts: 26
Joined: Fri Oct 23, 2015 11:51 am

Rpi Hotspot

Post by bricolodu13 »

Hello,

I did a fresh install and the Hotspot mode is not working as per following:

Code: Select all

root@DietPi:~# dietpi-config
[  OK  ] DietPi-Config | Root access verified.
[  OK  ] DietPi-Config | RootFS R/W access verified.
[.     ] DietPi-Config | systemctl start hostapd
[FAILED] DietPi-Config | systemctl start hostapd


--------------------------------------------------------------------
- DietPi has encounted an error, and, is unable to continue        -
- Please create a ticket: https://github.com/MichaIng/DietPi/issues -
- Copy and paste the BLUE lines below, into the ticket             -
--------------------------------------------------------------------


#### Details:
- Date           | Sun 15 Sep 13:38:06 BST 2019
- Bug report     | N/A
- DietPi version | v6.25.3 (MichaIng/master)
- Img creator    | DietPi Core Team
- Pre-image      | Raspbian Lite
- SBC device     | RPi 3 Model B+ (armv7l) (index=3)
- Kernel version | #1253 SMP Thu Aug 15 11:49:46 BST 2019
- Distro         | buster (index=5)
- Command        | systemctl start hostapd
- Exit code      | 1
- Software title | DietPi-Config

#### Steps to reproduce:
<!-- Explain how to reproduce the issue -->
1. ...
2. ...

#### Expected behaviour:
<!-- What SHOULD be happening? -->
- ...

#### Actual behaviour:
<!-- What IS happening? -->
- ...

#### Extra details:
<!-- Please post any extra details that might help solve the issue -->
- ...

#### Additional logs:
```
Log file contents:
Failed to start hostapd.service: Unit hostapd.service is masked.
```


--------------------------------------------------------------------

[FAILED] DietPi-Config | Unable to continue, DietPi-Config will now terminate.
I tried to solve the issue with the following command but got another error.

Code: Select all

systemctl unmask hostapd
sudo systemctl enable hostapd
sudo systemctl start hostapd
Any idea ?

Best regards,
Jean
Post Reply