Build ffmpeg with fdk-aac? Topic is solved

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
Posts: 6
Joined: Wed Sep 12, 2018 8:40 am

Build ffmpeg with fdk-aac?

Post by shred »

Edit: Figured it out, just need to install lib tools

Code: Select all

sudo apt-get install libtools

I'm trying to get audio support for a Homebridge plugin to work following these instructions: ... io-support

The first thing I tried was using the dietpi-software tool to install ffmpeg but it builds without fdk-aac. Trying to use the instructions above, I get the following error after executing

Code: Select all


Code: Select all

autoreconf: Entering directory `.'
autoreconf: not using Gettext
autoreconf: running: aclocal --force -I m4
autoreconf: tracing
autoreconf: not using Libtool
autoreconf: running: /usr/bin/autoconf --force
autoreconf: not using Autoheader
autoreconf: running: automake --add-missing --copy --force-missing error: Libtool library used but 'LIBTOOL' is undefined   The usual way to define 'LIBTOOL' is to add 'LT_INIT'   to '' and run 'aclocal' and 'autoconf' again.   If 'LT_INIT' is in '', make sure   its definition is in aclocal's search path.
autoreconf: automake failed with exit status: 1
Any ideas how I can build ffmpeg on diet with fdk-aac enabled?

User avatar
Site Admin
Posts: 3087
Joined: Sat Nov 18, 2017 6:21 pm

Re: Build ffmpeg with fdk-aac?

Post by MichaIng »

Hmm, is libtool probably simply missing? apt install libtool
Post Reply