The Lounge (IRC Client) on DietPi Topic is solved

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
Puunda
Posts: 6
Joined: Tue Jul 09, 2019 5:10 pm

The Lounge (IRC Client) on DietPi

Post by Puunda »

Hey guys,
I'd love to run "The Lounge" on my DietPi, but I'm 75% a noob and if errors happen I'm often instantly lost. This time I installed Nodes.js from dietpi-software and "npg install -g thelounge". Got some errors, didn't know what to do. Now I'm kinda proud I just rolled back without braking anything, but still, I'd love to have The Lounge on my DietPi.
Any help? Or do you want to add it as optimised software?

Anyway: DietPi ist the best! Thanks a lot for this great OS!!!
User avatar
MichaIng
Site Admin
Posts: 2621
Joined: Sat Nov 18, 2017 6:21 pm

Re: The Lounge (IRC Client) on DietPi

Post by MichaIng »

@Puunda
Could you paste the exact error messages you face when trying to install with npm?

Also did you try it with the official deb package: https://github.com/thelounge/thelounge/releases

Code: Select all

cd /tmp
wget https://github.com/thelounge/thelounge/releases/download/v3.1.1/thelounge_3.1.1-1_all.deb
dpkg -i thelounge_3.1.1-1_all.deb
apt-get -f install
rm thelounge_3.1.1-1_all.deb
Puunda
Posts: 6
Joined: Tue Jul 09, 2019 5:10 pm

Re: The Lounge (IRC Client) on DietPi

Post by Puunda »

That worked, thanks a lot. I had to install nodes.js from dietpi-software first, everything working fine now.
layentara
Posts: 3
Joined: Tue Feb 02, 2021 4:17 pm

Re: The Lounge (IRC Client) on DietPi

Post by layentara »

Hello, I've a problem with the installation of TheLounge: I downloaded the latest release, but after executing
dpkg -i thelounge_4.2.0_all.deb; I get this error:

Image

I have already installed nodejs in advance via dietpi-software.

Would reinstalling nodejs fix it?
User avatar
MichaIng
Site Admin
Posts: 2621
Joined: Sat Nov 18, 2017 6:21 pm

Re: The Lounge (IRC Client) on DietPi

Post by MichaIng »

Run the following to have dependencies automatically installed:

Code: Select all

apt install ./thelounge_4.2.0_all.deb
layentara
Posts: 3
Joined: Tue Feb 02, 2021 4:17 pm

Re: The Lounge (IRC Client) on DietPi

Post by layentara »

MichaIng wrote: Tue Feb 02, 2021 5:40 pm Run the following to have dependencies automatically installed:

Code: Select all

apt install ./thelounge_4.2.0_all.deb

I did; this is the output:

Image

Is this normal? Should I execute apt --fix-broken install? Sorry, I'm a beginner ;)
User avatar
Joulinar
Posts: 3758
Joined: Sat Nov 16, 2019 12:49 am

Re: The Lounge (IRC Client) on DietPi

Post by Joulinar »

yes that would be an option to run apt --fix-broken install
Pls let us know if a solution is working. This could help others if they hit by similar situation. Your DietPi Team
layentara
Posts: 3
Joined: Tue Feb 02, 2021 4:17 pm

Re: The Lounge (IRC Client) on DietPi

Post by layentara »

That seemsed to work. However, I still face some errors. Trying to handle them myself, but I can access TheLounge via my browser.
Post Reply