Speedtouch 121g deauth reason 3

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
W00fer

Speedtouch 121g deauth reason 3

Post by W00fer »

Hi,

I've got a Speedtouch 121g wifi stick which internally is a Intersil ISL3887.

USB: 06B9:0121 Alcatel Telecom SpeedTouch 121g Wireless Dongle

It works, with the firmware from here:

http://domoticx.com/firmware-linux-inte ... e-prism54/

But deauths after random time.
From what I have read I should disable IPV6, and connect to a powered usb hub.

I both tried that but it still goes offline after a while. Only ifup wlan0 reactivates it (through UART)

Running Dietpi v129
Linux 4.4.17

Screenshots with the deauth message:
dietpi-wlan1.png
dietpi-wlan2.png
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Speedtouch 121g deauth reason 3

Post by Fourdee »

Hi w00fer,

> But deauths after random time.

Sounds like a possible powersaving mode, or buggy firmware/driver.

Does this device show up as a module (eg: isl3886pci)?

Code: Select all

lsmod
Try running:

Code: Select all

dmesg | grep modulename
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply