O!MPD player panel broken after update

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
bamyasi
Posts: 25
Joined: Tue Jan 29, 2019 2:26 am

O!MPD player panel broken after update

Post by bamyasi »

Hi all,

Upgraded to DietPi v6.25.3 today, worked like a charm, great job! But now I am having a strange looking additional panel displayed at the bottom of my O!MPD Library page. The new panel I suppose is intended to give fast access to the player but it only shows blank disk icon and some text next to it, e.g.:

3/30.
by from

And that's all. Now 3/30 looks like the number of currently played track / total number of tracks in the playlist but the 'by from' I assume should be listing track / artist / album name except this does not work as intended, all the fields are always blank. And no album icon shown either. Anybody else seeing the same issue and how to fix it?

Thanks,
bamyasi
User avatar
MichaIng
Site Admin
Posts: 2295
Joined: Sat Nov 18, 2017 6:21 pm

Re: O!MPD player panel broken after update

Post by MichaIng »

@bamyasi
Which SBC and which webserver do you use?

O!MPD has been updated to quite a much newer versions, so I guess there are some UI changes. Did you update the MPD music library once from Settings > Update > Update all?

I just did a test install and after choosing some song to play, then navigating back to e.g. Library or Favourites, the bottom panel shows the song which is played with artist and title (if available from file meta data) and I am able to pause/resume or switch to previous/next song. So this works as intended here.
Tested with Lighttpd on x86_64 VM.
bamyasi
Posts: 25
Joined: Tue Jan 29, 2019 2:26 am

Re: O!MPD player panel broken after update

Post by bamyasi »

@MichaIng
O!MPD maintainer also was unable to reproduce the bug on a freshly installed DietPi:

https://github.com/ArturSierzant/OMPD/issues/91

So I guess it is some kind of local misconfiguration caused by incremental upgrades. Any hints where I might look on my system to try to debug it? Permission issue?

BTW, on my system miniplayer is also operational, I can pause / resume / skip tracks using its buttons. It's just album art and various other metadata (e.g. track / album / artist name) which is missing (blank). Could be some font missing?
bamyasi
Posts: 25
Joined: Tue Jan 29, 2019 2:26 am

Re: O!MPD player panel broken after update

Post by bamyasi »

FYI: As it turned out, to fix the issue a new instance of MPD player needs to be created via the O!MPD web interface. See the GitHub ticket linked below for detailed instructions from the maintainer:

https://github.com/ArturSierzant/OMPD/issues/91
User avatar
MichaIng
Site Admin
Posts: 2295
Joined: Sat Nov 18, 2017 6:21 pm

Re: O!MPD player panel broken after update

Post by MichaIng »

@bamyasi
Hmm, is it due to some version incompatibilities? Any actions required from our side that you would suggest? Sorry I did not yet go through the GitHub issue you linked.
Post Reply