DietPi Image does not work with Rock64V3

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
favstarmafia
Posts: 3
Joined: Sun May 19, 2019 7:25 pm

DietPi Image does not work with Rock64V3

Post by favstarmafia »

I bought a new Rock64, which is now delivered in the version V3. With this Rock64 the DietPi image doesn't work, because the system doesn't boot. Is this problem already known?
User avatar
MichaIng
Site Admin
Posts: 2423
Joined: Sat Nov 18, 2017 6:21 pm

Re: DietPi Image does not work with Rock64V3

Post by MichaIng »

@favstarmafia
Nope, issue not known. I guess we will ship a new Debian Buster based image soon.

You could try this ARMbian image as basis: https://dl.armbian.com/rock64/Debian_buster_default.7z
If this boots fine, run DietPi-PREP script to install/turn it into a DietPi system: https://github.com/MichaIng/DietPi/issu ... -280771944
bob.stone
Posts: 1
Joined: Tue Jul 09, 2019 7:20 am

Re: DietPi Image does not work with Rock64V3

Post by bob.stone »

@MichaIng , thanks a lot for your suggestion. I did try the solution with different source image from https://github.com/ayufan-rock64/linux- ... m64.img.xz and can confirm Diet-PREP script works just fine. I was able to create DietPi installation with it. The issue I had after that is KODI installation is not available for the Rock64. It's not available from dietpi-software tool. if I run "dietpi-software install 31" I got the error "Kodi is not supported by Rock64". Your advice would be greatly appreciated
User avatar
MichaIng
Site Admin
Posts: 2423
Joined: Sat Nov 18, 2017 6:21 pm

Re: DietPi Image does not work with Rock64V3

Post by MichaIng »

@bob.stone
Sorry for late reply. We btw never supported Kodi on Rock64, most likely because GPU acceleration was missing for this device. I am currently testing some solutions for this and then we can test Kodi as well.

For now at least what can be tested is simply install the APT package:
apt install kodi
AFAIK the Ayufan Buster image comes with some GPU acceleration repo enabled (one in /etc/apt/sources.list.d/) from where one can install the Mali GPU drivers:
apt install libmali-rk-utgard-450-r7p0
Post Reply