DietPi on LXC and how to disable autofs ?

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
jodumont
Posts: 1
Joined: Thu Jun 20, 2019 9:26 pm

DietPi on LXC and how to disable autofs ?

Post by jodumont »

I successfully installed DietPi on top of a unprivileged Debian LXContainer by commenting few lines about swap and grub in PREP_SYSTEM_FOR_DIETPI.sh

then disactivating the TimeSync
and mount a second drive for /mnt/dietpi_userdata

Now everything seams running smoothly at the exeption of autofs4 is complaining
[ INFO ] DietPi-Drive_Manager | autofs4 module not available in kernel, x-systemd.automount has been disabled

I wonder how and where I could stop autofs ?
User avatar
MichaIng
Site Admin
Posts: 2295
Joined: Sat Nov 18, 2017 6:21 pm

Re: DietPi on LXC and how to disable autofs ?

Post by MichaIng »

@jodumont
Most probably this container or machine simply has no support for this module. If modinfo autofs4 does not show info about it, its simply not available, otherwise check modprobe autofs4 for error message/reason.

However it is not an issue/error, just an info. By default drive manager adds x-systemd.automount to external drive mount options. However actually in combination with auto this does not even make much sense... With noauto it leads to those drives no being mounted on boot, but on first access to the mount point instead. But yeah I see no real benefit of this.

So long story short: If you simply want your drive to be accessible at boot, and this is anyway required for dietpi_userdata, ignore the message, everything is fine :).
Post Reply