Active screen?? Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Zarquon
Posts: 2
Joined: Fri May 24, 2019 8:13 pm

Active screen??

Post by Zarquon » Fri May 24, 2019 8:22 pm

Hi there,
got this note after booting up, while connected via Putty (SSH):

DietPi first run setup: Currently running on another screen (PID=683)
Please resume setup on the active screen.

The setting is a headless Pi zero W with a camera module installed, nothing else. I don't want to install the whole system again, so if anyone has an idea to fix this??

Cheers Zarc

User avatar
MichaIng
Legend
Posts: 1626
Joined: Sat Nov 18, 2017 5:21 pm

Re: Active screen??

Post by MichaIng » Sun Jun 09, 2019 11:36 pm

@Zarquon
Hmm strange, have you changed the autostart option to auto login? Of course this will not work on a headless system.

However you can manually kill the running process.
When hitting Ok in the prompt, you should be able to press CTRL+C to exit the login script. Then run: htop
You should see one dietpi-login or /DietPi/dietpi/login instance running. If it indeed is hanging (0% CPU usage), then select it via up/down buttons and press F9 + return to kill it.

Then logout the SSH session and login again and you should see first run setup running on the SSH session.

Zarquon
Posts: 2
Joined: Fri May 24, 2019 8:13 pm

Re: Active screen??

Post by Zarquon » Fri Jun 14, 2019 5:28 pm

@MichaIng

Hi, that procedere saved the day. I killed a few processes, entered installation routine again, rebooted and learn the command htop :-)) thanks, problem solved. Cheers Zarc

Post Reply