Unable to update from v6.22.3 to v6.24.1 Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
ohjk
Posts: 1
Joined: Sun May 19, 2019 12:07 am

Unable to update from v6.22.3 to v6.24.1

Post by ohjk »

Hi, this is the message I receive when running dietpi-update:

root@DietPi:~# dietpi-update
[ OK ] DietPi-Update | Root access verified.
[ OK ] DietPi-Update | RootFS R/W access verified.


DietPi-Update
─────────────────────────────────────────────────────
Mode: Checking for DietPi updates

[ INFO ] DietPi-Update | Checking mirror: https://raw.githubusercontent.com/Micha ... _version-6
[ OK ] DietPi-Update | Using update server: https://raw.githubusercontent.com/Micha ... _version-6

[ OK ] DietPi-Update | Update available
[ INFO ] DietPi-Update | Current version : v6.22.3 (branch: Fourdee/master)
[ INFO ] DietPi-Update | Latest version : v6.24.1 (branch: MichaIng/master)
[ OK ] DietPi-Update | DietPi-Userdata validation: /mnt/dietpi_userdata
[ OK ] DietPi-Update | Free space check: path=/ | available=24832 MiB | required=100 MiB
[ SUB1 ] DietPi-Services > stop
[ OK ] DietPi-Services | stop : cron
[ OK ] DietPi-Services | stop : docker
[ OK ] DietPi-Services | stop : lighttpd
[ OK ] DietPi-Update | wget https://raw.githubusercontent.com/Micha ... patch_file -O pre-patch_file

DietPi-Pre-patch
─────────────────────────────────────────────────────
Mode: Applying pre-patches

[ OK ] Successfully applied pre-patches

[ INFO ] DietPi-Update | APT update, please wait...
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 https://download.docker.com/linux/raspbian stretch InRelease
Hit:3 https://archive.raspberrypi.org/debian stretch InRelease
Reading package lists...
[ OK ] DietPi-Update | G_AGUP
[ INFO ] DietPi-Update | APT upgrade, please wait...
[ OK ] DietPi-Update | G_AGUG
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 120 0 120 0 0 393 0 --:--:-- --:--:-- --:--:-- 393
curl: (7) Failed to connect to codeload.github.com port 443: Connection refused
[FAILED] DietPi-Update | Download failed, unable to run update. Please try running dietpi-update again.
favstarmafia
Posts: 3
Joined: Sun May 19, 2019 7:25 pm

Re: Unable to update from v6.22.3 to v6.24.1

Post by favstarmafia »

I have also had the problem for several days that an update is no longer possible, I always get the following error message

Code: Select all

DietPi-Pre-patch
─────────────────────────────────────────────────────
 Mode: Applying pre-patches

[  OK  ] Successfully applied pre-patches

[ INFO ] DietPi-Update | APT update, please wait...
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 http://packages.prosody.im/debian stretch InRelease
Hit:3 https://archive.raspberrypi.org/debian stretch InRelease
Reading package lists...
[  OK  ] DietPi-Update | G_AGUP
[ INFO ] DietPi-Update | APT upgrade, please wait...
[  OK  ] DietPi-Update | G_AGUG
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   120    0   120    0     0    326      0 --:--:-- --:--:-- --:--:--   326
curl: (7) Failed to connect to codeload.github.com port 443: Connection refused
[FAILED] DietPi-Update | Download failed, unable to run update. Please try running dietpi-update again.
jefish
Posts: 1
Joined: Sun May 19, 2019 10:08 pm

Re: Unable to update from v6.22.3 to v6.24.1

Post by jefish »

Same issue. Can't update from v6.21.1 to v6.24.1

curl: (7) Failed to connect to codeload.github.com port 443: Connection refused
[FAILED] DietPi-Update | Download failed, unable to run update. Please try running dietpi-update again.
trembler
Posts: 4
Joined: Wed Jan 30, 2019 9:17 pm

Re: Unable to update from v6.22.3 to v6.24.1

Post by trembler »

Make sure codeload.github.com is not blocked by pihole
favstarmafia
Posts: 3
Joined: Sun May 19, 2019 7:25 pm

Re: Unable to update from v6.22.3 to v6.24.1

Post by favstarmafia »

Thank you, that was the problem, now the update worked!!
Post Reply