libssl1.1 breaks lighttpd Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
disco4000
Posts: 3
Joined: Thu May 16, 2019 2:12 pm

libssl1.1 breaks lighttpd

Post by disco4000 »

After upgrading to 6.24 and PHP 7.3, lighttpd is broken and won't start, neither reinstall due to the known issue with libssl1.1 for versions below 1.4.51.
Is there an option to install the newer version from one of the repos?
RPi1 - DietPi 6.24.1
maarten
Posts: 34
Joined: Mon Nov 19, 2018 4:35 pm

Re: libssl1.1 breaks lighttpd

Post by maarten »

I experience exactly the same issue.

All went well (thanks Micha and Fourdee for all the good and hard work), except that lighttpd will not start. Is there a workaround or solution to get lighttpd up and running again?

Thanks, Maarten
User avatar
MichaIng
Site Admin
Posts: 2295
Joined: Sat Nov 18, 2017 6:21 pm

Re: libssl1.1 breaks lighttpd

Post by MichaIng »

@disco4000
On which device are you trying it? RPi1 or Zero?

On all other systems, where we install PHP7.3 from sury.org repo, we actively block the libssl1.1 upgrade for this reason. On ARMv6 systems, where we use the Buster repo (now), the libssl1.1 upgrade must be done but pulls in the new Lighttpd version automatically. At least this was the case during my and @maarten's test.

Please paste the following:

Code: Select all

apt policy lighttpd libssl1.1 
disco4000
Posts: 3
Joined: Thu May 16, 2019 2:12 pm

Re: libssl1.1 breaks lighttpd

Post by disco4000 »

I tried it on my RPi1.
Thanks for your advice. I'm on vacation now for 10 days and can't test it though, but will as soon as I'm back.

Regards, d.
RPi1 - DietPi 6.24.1
maiis
Posts: 2
Joined: Sun May 19, 2019 12:13 pm

Re: libssl1.1 breaks lighttpd

Post by maiis »

Hi,

I'm facing the same issue, and can't reinstall, on a Rpi1:

Code: Select all

[ INFO ] DietPi-Software | APT installation for: lighttpd perl, please wait...
E: Unable to correct problems, you have held broken packages.
[FAILED] DietPi-Software | G_AGI lighttpd perl

Code: Select all

root@DietPi:~# apt policy lighttpd libssl1.1 
lighttpd:
  Installed: (none)
  Candidate: 1.4.45-1
  Version table:
     1.4.53-4 100
        100 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
     1.4.45-1 500
        500 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages
libssl1.1:
  Installed: 1.1.1b-2
  Candidate: 1.1.1b-2
  Version table:
 *** 1.1.1b-2 100
        100 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
        100 /var/lib/dpkg/status
     1.1.0j-1~deb9u1 500
        500 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages
    
User avatar
MichaIng
Site Admin
Posts: 2295
Joined: Sat Nov 18, 2017 6:21 pm

Re: libssl1.1 breaks lighttpd

Post by MichaIng »

@maiis
With the DietPi v6.24.1 we tuned the Buster repo priority pins a bid to allow installing all required packages for PHP7.3 and Lighttpd from Buster.

Did this help?
maiis
Posts: 2
Joined: Sun May 19, 2019 12:13 pm

Re: libssl1.1 breaks lighttpd

Post by maiis »

Yes, after the last dietpi-update it worked, thanks 8)
disco4000
Posts: 3
Joined: Thu May 16, 2019 2:12 pm

Re: libssl1.1 breaks lighttpd

Post by disco4000 »

I also can confirm: 6.24.1 fixes the problem, everything back to normal.

Thank you
RPi1 - DietPi 6.24.1
Post Reply