Automated installation failing on "connection test" Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
User avatar
k-plan
Posts: 416
Joined: Sun Feb 28, 2016 5:28 pm

Re: Automated installation failing on "connection test"

Post by k-plan »

Hi,

which image did you use? DietPi_RPi-armv6-(Jessie) or DietPi_RPi-armv6-(Wheezy) ?



Whats did Network Options: Adapters shows in dietpi-config ?
Network Options: Adapters
Network Options: Adapters

What happens, when you hit "Scan and connect"
scan
scan
Scan and connect
Scan and connect
160917-0002.gif (11.57 KiB) Viewed 3138 times

On which wifi channel runs your accesspoint/wifi-router ?

WiFi country code is set ?

Output from:

Code: Select all

lsusb

cat /etc/network/interfaces
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.
tohax
Posts: 4
Joined: Fri Sep 16, 2016 2:03 pm

Re: Automated installation failing on "connection test"

Post by tohax »

I am using DietPi_RPi-armv6-(Jessie). When i hit "Scan and connect" it find my ssid, then i enter password, and during network service restarting i get errors (NETLINK: error: invalid argument) and network is not working. If i choose DHCP then "scan and connect" and continue, i am getting IP address and other parameters, and network start working. But i need static network parameters applying during 1st boot. I think, that set WiFi country code is not necessary(am i wrong?) i tried set it up to RU and US, but it is not solve the problem. I have TP-Link 1043 nd v1 router with openwrt. WiFi working on 11 channel. but i tried others - no result. Do you have jessie v127 image? Because on v127 ALL working fine. Maybe new kernel is the problem or drivers for RTL8192?(my wifi adapter) Thanks for your help!
Attachments
NETLINK error.jpg
Scan and connect.jpg
lsusb.jpg
Network Options Adapters .jpg
User avatar
k-plan
Posts: 416
Joined: Sun Feb 28, 2016 5:28 pm

Re: Automated installation failing on "connection test"

Post by k-plan »

Hi,

thanks tohax for reporting this :!:

Testing with:

- RPi B+
- image: DietPi_v130_RPi-armv6-(Jessie).img
- changes in dietpi.txt

Code: Select all

Ethernet_Enabled=0
Wifi_Enabled=1

Use_Static=1

AUTO_Install_Enable=1

wifi_country_code=DE
- wifi adapter (chipset - Realtek 8192cu ):

Code: Select all

:~# lsusb
Bus 001 Device 005: ID 7392:7822 Edimax Technology Co., Ltd

Code: Select all

:~# lsmod
Module                  Size  Used by
brcmfmac              201814  0
brcmutil                9031  1 brcmfmac
8192cu                597488  0
evdev                  11650  0
cfg80211              499234  2 brcmfmac,8192cu
rfkill                 21397  2 cfg80211
bcm2835_gpiomem         3823  0
bcm2835_wdt             4133  0
uio_pdrv_genirq         3718  0
uio                    10230  1 uio_pdrv_genirq
fuse                   90152  1
ipv6                  367575  14

Result:
- booting up with static IP on wifi and disabled ethernet ==>> no IP address, no IP connection
- switching via dietpi-config to DHCP ==>> IP address and IP connection will work

Code: Select all

:~# uname -a
Linux RPi-B 4.4.19+ #907 Tue Sep 6 13:45:45 BST 2016 armv6l GNU/Linux
dmesg output while switching form DHCP => static IP

Code: Select all

....

[   16.149262] cfg80211: Regulatory domain changed to country: DE
[   16.149305] cfg80211:  DFS Master region: ETSI
[   16.149320] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   16.149343] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   16.149361] cfg80211:   (5150000 KHz - 5250000 KHz @ 80000 KHz, 200000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[   16.149382] cfg80211:   (5250000 KHz - 5350000 KHz @ 80000 KHz, 200000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[   16.149399] cfg80211:   (5470000 KHz - 5725000 KHz @ 160000 KHz), (N/A, 2698 mBm), (0 s)
[   16.149415] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[   18.566603] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  126.235856] ------------[ cut here ]------------
[  126.236834] WARNING: CPU: 0 PID: 6 at net/wireless/sme.c:907 __cfg80211_disconnected+0x280/0x2c8 [cfg80211]()
[  126.236943] Modules linked in: 8192cu evdev cfg80211 rfkill bcm2835_gpiomem bcm2835_wdt uio_pdrv_genirq uio fuse ipv6
[  126.237010] CPU: 0 PID: 6 Comm: kworker/u2:0 Not tainted 4.4.19+ #907
[  126.237023] Hardware name: BCM2708
[  126.237819] Workqueue: cfg80211 cfg80211_event_work [cfg80211]
[  126.237974] [<c0016cfc>] (unwind_backtrace) from [<c0013c20>] (show_stack+0x20/0x24)
[  126.238013] [<c0013c20>] (show_stack) from [<c02e38fc>] (dump_stack+0x20/0x28)
[  126.238044] [<c02e38fc>] (dump_stack) from [<c0021eb4>] (warn_slowpath_common+0x8c/0xc4)
[  126.238069] [<c0021eb4>] (warn_slowpath_common) from [<c0021fa8>] (warn_slowpath_null+0x2c/0x34)
[  126.238872] [<c0021fa8>] (warn_slowpath_null) from [<bf0e6b84>] (__cfg80211_disconnected+0x280/0x2c8 [cfg80211])
[  126.240106] [<bf0e6b84>] (__cfg80211_disconnected [cfg80211]) from [<bf0c20ac>] (cfg80211_process_wdev_events+0x1a0/0x20c [cfg80211])
[  126.241303] [<bf0c20ac>] (cfg80211_process_wdev_events [cfg80211]) from [<bf0c2154>] (cfg80211_process_rdev_events+0x3c/0x74 [cfg80211])
[  126.242820] [<bf0c2154>] (cfg80211_process_rdev_events [cfg80211]) from [<bf0bd208>] (cfg80211_event_work+0x24/0x2c [cfg80211])
[  126.243498] [<bf0bd208>] (cfg80211_event_work [cfg80211]) from [<c0037540>] (process_one_work+0x11c/0x39c)
[  126.243535] [<c0037540>] (process_one_work) from [<c0037800>] (worker_thread+0x40/0x4d0)
[  126.243566] [<c0037800>] (worker_thread) from [<c003d184>] (kthread+0xdc/0xf8)
[  126.243604] [<c003d184>] (kthread) from [<c000f8a8>] (ret_from_fork+0x14/0x2c)
[  126.243620] ---[ end trace 22f719d6d6b64ab0 ]---
[  126.775192] usbcore: registered new interface driver brcmfmac
[  132.000263] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

...

[  134.346639] cfg80211: Regulatory domain changed to country: DE
[  134.346682] cfg80211:  DFS Master region: ETSI
[  134.346696] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[  134.346716] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[  134.346732] cfg80211:   (5150000 KHz - 5250000 KHz @ 80000 KHz, 200000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[  134.346747] cfg80211:   (5250000 KHz - 5350000 KHz @ 80000 KHz, 200000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[  134.346760] cfg80211:   (5470000 KHz - 5725000 KHz @ 160000 KHz), (N/A, 2698 mBm), (0 s)
[  134.346772] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[  135.715603] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  168.261838] ------------[ cut here ]------------
[  168.262769] WARNING: CPU: 0 PID: 62 at net/wireless/sme.c:907 __cfg80211_disconnected+0x280/0x2c8 [cfg80211]()
[  168.262795] Modules linked in: brcmfmac brcmutil 8192cu evdev cfg80211 rfkill bcm2835_gpiomem bcm2835_wdt uio_pdrv_genirq uio fuse ipv6
[  168.262859] CPU: 0 PID: 62 Comm: kworker/u2:2 Tainted: G        W       4.4.19+ #907
[  168.262870] Hardware name: BCM2708
[  168.263558] Workqueue: cfg80211 cfg80211_event_work [cfg80211]
[  168.263872] [<c0016cfc>] (unwind_backtrace) from [<c0013c20>] (show_stack+0x20/0x24)
[  168.263909] [<c0013c20>] (show_stack) from [<c02e38fc>] (dump_stack+0x20/0x28)
[  168.263943] [<c02e38fc>] (dump_stack) from [<c0021eb4>] (warn_slowpath_common+0x8c/0xc4)
[  168.263968] [<c0021eb4>] (warn_slowpath_common) from [<c0021fa8>] (warn_slowpath_null+0x2c/0x34)
[  168.264817] [<c0021fa8>] (warn_slowpath_null) from [<bf0e6b84>] (__cfg80211_disconnected+0x280/0x2c8 [cfg80211])
[  168.266073] [<bf0e6b84>] (__cfg80211_disconnected [cfg80211]) from [<bf0c20ac>] (cfg80211_process_wdev_events+0x1a0/0x20c [cfg80211])
[  168.267319] [<bf0c20ac>] (cfg80211_process_wdev_events [cfg80211]) from [<bf0c2154>] (cfg80211_process_rdev_events+0x3c/0x74 [cfg80211])
[  168.268812] [<bf0c2154>] (cfg80211_process_rdev_events [cfg80211]) from [<bf0bd208>] (cfg80211_event_work+0x24/0x2c [cfg80211])
[  168.269651] [<bf0bd208>] (cfg80211_event_work [cfg80211]) from [<c0037540>] (process_one_work+0x11c/0x39c)
[  168.269696] [<c0037540>] (process_one_work) from [<c0037800>] (worker_thread+0x40/0x4d0)
[  168.269730] [<c0037800>] (worker_thread) from [<c003d184>] (kthread+0xdc/0xf8)
[  168.269765] [<c003d184>] (kthread) from [<c000f8a8>] (ret_from_fork+0x14/0x2c)
[  168.269780] ---[ end trace 22f719d6d6b64ab1 ]---
[  173.915893] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

Have create a github issue for this: https://github.com/Fourdee/DietPi/issues/515

----

Solution at the moment:

- only use DHCP for wifi


-------------

UPDATE

Testing again with same config but DietPi_v127_RPi-armv6-(Jessie).img

Result:
- booting up with static IP on wifi and disabled ethernet ==>> IP address and IP connection will work ==> auto-update to DietPi_v130
- switching via dietpi-config to DHCP ==>> IP address and IP connection will work

Code: Select all

root@RPi-B:~# uname -a
Linux RPi-B 4.4.16+ #899 Thu Jul 28 12:36:19 BST 2016 armv6l GNU/Linux
... but the same annoying dmesg output:

Code: Select all

[   11.871090] usbcore: registered new interface driver rtl8192cu
[   12.156795] cfg80211: Regulatory domain changed to country: DE
[   12.156838] cfg80211:  DFS Master region: ETSI
[   12.156854] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   12.156880] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   12.156901] cfg80211:   (5150000 KHz - 5250000 KHz @ 80000 KHz, 200000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[   12.156920] cfg80211:   (5250000 KHz - 5350000 KHz @ 80000 KHz, 200000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[   12.156937] cfg80211:   (5470000 KHz - 5725000 KHz @ 160000 KHz), (N/A, 2698 mBm), (0 s)
[   12.156952] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[   13.973864] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   15.763437] Adding 102396k swap on /var/swap.  Priority:-1 extents:2 across:126972k SSFS
[   15.897195] cfg80211: World regulatory domain updated:
[   15.897238] cfg80211:  DFS Master region: unset
[   15.897255] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   15.897279] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   15.897295] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   15.897311] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   15.897330] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[   15.897349] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[   15.897365] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   15.897382] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   15.897398] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   16.033289] cfg80211: Regulatory domain changed to country: DE
[   16.033331] cfg80211:  DFS Master region: ETSI
[   16.033347] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   16.033369] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   16.033392] cfg80211:   (5150000 KHz - 5250000 KHz @ 80000 KHz, 200000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[   16.033412] cfg80211:   (5250000 KHz - 5350000 KHz @ 80000 KHz, 200000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[   16.033429] cfg80211:   (5470000 KHz - 5725000 KHz @ 160000 KHz), (N/A, 2698 mBm), (0 s)
[   16.033445] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[   18.447248] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   97.391629] ------------[ cut here ]------------
[   97.392608] WARNING: CPU: 0 PID: 6 at net/wireless/sme.c:907 __cfg80211_disconnected+0x280/0x2c8 [cfg80211]()
[   97.392633] Modules linked in: 8192cu evdev cfg80211 rfkill bcm2835_gpiomem bcm2835_wdt uio_pdrv_genirq uio fuse ipv6
[   97.392698] CPU: 0 PID: 6 Comm: kworker/u2:0 Not tainted 4.4.16+ #899
[   97.392710] Hardware name: BCM2708
[   97.393441] Workqueue: cfg80211 cfg80211_event_work [cfg80211]
[   97.393524] [<c0016c9c>] (unwind_backtrace) from [<c0013c20>] (show_stack+0x20/0x24)
[   97.393559] [<c0013c20>] (show_stack) from [<c02e359c>] (dump_stack+0x20/0x28)
[   97.393594] [<c02e359c>] (dump_stack) from [<c0021e54>] (warn_slowpath_common+0x8c/0xc4)
[   97.393619] [<c0021e54>] (warn_slowpath_common) from [<c0021f48>] (warn_slowpath_null+0x2c/0x34)
[   97.394371] [<c0021f48>] (warn_slowpath_null) from [<bf0e5b84>] (__cfg80211_disconnected+0x280/0x2c8 [cfg80211])
[   97.395652] [<bf0e5b84>] (__cfg80211_disconnected [cfg80211]) from [<bf0c10ac>] (cfg80211_process_wdev_events+0x1a0/0x20c [cfg80211])
[   97.397143] [<bf0c10ac>] (cfg80211_process_wdev_events [cfg80211]) from [<bf0c1154>] (cfg80211_process_rdev_events+0x3c/0x74 [cfg80211])
[   97.398609] [<bf0c1154>] (cfg80211_process_rdev_events [cfg80211]) from [<bf0bc208>] (cfg80211_event_work+0x24/0x2c [cfg80211])
[   97.399611] [<bf0bc208>] (cfg80211_event_work [cfg80211]) from [<c00374e0>] (process_one_work+0x11c/0x39c)
[   97.399656] [<c00374e0>] (process_one_work) from [<c00377a0>] (worker_thread+0x40/0x4d0)
[   97.399686] [<c00377a0>] (worker_thread) from [<c003d124>] (kthread+0xdc/0xf8)
[   97.399723] [<c003d124>] (kthread) from [<c000f8a8>] (ret_from_fork+0x14/0x2c)
[   97.399738] ---[ end trace f13b9e6ac140c28b ]---
[   97.933622] usbcore: registered new interface driver brcmfmac
[  103.180406] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  105.454529] cfg80211: World regulatory domain updated:
[  105.454574] cfg80211:  DFS Master region: unset
[  105.454589] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[  105.454610] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[  105.454625] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[  105.454639] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[  105.454653] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[  105.454670] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[  105.454683] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[  105.454696] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[  105.454710] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[  105.545701] cfg80211: Regulatory domain changed to country: DE
[  105.545742] cfg80211:  DFS Master region: ETSI
[  105.545756] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[  105.545777] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[  105.545793] cfg80211:   (5150000 KHz - 5250000 KHz @ 80000 KHz, 200000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[  105.545812] cfg80211:   (5250000 KHz - 5350000 KHz @ 80000 KHz, 200000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[  105.545825] cfg80211:   (5470000 KHz - 5725000 KHz @ 160000 KHz), (N/A, 2698 mBm), (0 s)
[  105.545838] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[  106.914932] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal and Bitcoin.
tohax
Posts: 4
Joined: Fri Sep 16, 2016 2:03 pm

Re: Automated installation failing on "connection test"

Post by tohax »

Thank you very much! Waiting for v131 to come out
Post Reply