Warning: update v6.23 seems to have completely bricked my installation...

Having issues with your DietPi installation, or, found a bug? Post it here.
User avatar
MichaIng
Legend
Posts: 1228
Joined: Sat Nov 18, 2017 5:21 pm

Re: Warning: update v6.23 seems to have completely bricked my installation...

Post by MichaIng » Thu May 16, 2019 12:45 am

Hey guys,

many sorry for the very critical bug on ARMv6 devices. We blocked the update for ARMv6 yesterday and now just released v6.24 as hotfix to solve those + reopen for ARMv6.

I was shocked how a single incompatible APT package can corrupt the whole init system (systemd). We know now that that sury.org repo armhf packages are safe to run on ARMv7 or higher only, actually this is true for the whole Debian repo as well. Raspbian goes a special way to ship armv6l compatible armhf packages.

However on ARMv6 we now install PHP7.3 from the Buster repo (Raspbian Buster). Those packages are guaranteed to be compatible with the device/arch however some more dependency packages/libraries from Buster are installed. This is not a big issue (since Buster is close to become the new Debian stable version), but good to have in mind.

aa6tem
Posts: 3
Joined: Tue May 14, 2019 2:55 pm

Re: Warning: update v6.23 seems to have completely bricked my installation...

Post by aa6tem » Fri May 17, 2019 10:10 am

Hi

Now it doesnt brick the system but lighthttpd doenst start anymore

May 17 11:06:01 host lighttpd[1105]: /bin/sh: 1: /usr/share/lighttpd/create-mime.assign.pl: not found
May 17 11:06:01 host lighttpd[1105]: 2019-05-17 11:05:59: (configfile.c.1461) command "/usr/share/lighttpd/create-mime.assign.pl" exited non-zero: 127
May 17 11:06:01 host lighttpd[1105]: 2019-05-17 11:05:59: (configfile.c.1289) source: /etc/lighttpd/lighttpd.conf line: 27 pos: 14 parser failed somehow near here: (EOL)

User avatar
MichaIng
Legend
Posts: 1228
Joined: Sat Nov 18, 2017 5:21 pm

Re: Warning: update v6.23 seems to have completely bricked my installation...

Post by MichaIng » Fri May 17, 2019 12:42 pm

@aa6tem
Please try the following:

Code: Select all

sed -i 's/create-mime\.assign\.pl/create-mime.conf.pl/g' /etc/lighttpd/lighttpd.conf
dietpi-services restart lighttpd

aa6tem
Posts: 3
Joined: Tue May 14, 2019 2:55 pm

Re: Warning: update v6.23 seems to have completely bricked my installation...

Post by aa6tem » Fri May 17, 2019 3:21 pm

Great!!!!! Thank you so much!

Post Reply