dietpi-netdata is outdated

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
uga
Posts: 16
Joined: Fri Mar 29, 2019 11:45 am

dietpi-netdata is outdated

Post by uga »

I installed dietpi-netdata on my dietpi-raspberry3

While trying to amend configuration I ran into the following issue:

Code: Select all

root@DietPi:/usr/lib/netdata/conf.d# /etc/netdata/edit-config charts.d.conf
File 'charts.d.conf' is not found in '/usr/local/lib/netdata/conf.d'
Searching Netdata's site, this seems to be a known issue, solved a few versions ago.

According to their website, Netdata's current version is 1.14.0

I tried

Code: Select all

apt-get install --only-upgrade netdata
and I got

Code: Select all

netdata is already the newest version (1.11.1-1).
How can I proceed?
User avatar
MichaIng
Site Admin
Posts: 2265
Joined: Sat Nov 18, 2017 6:21 pm

Re: dietpi-netdata is outdated

Post by MichaIng »

@uga
The version of the APT (that we install) has been updated to 1.12: https://packages.debian.org/stretch-backports/netdata
Does this fix the issue? Otherwise isn't it possible to manually edit the configs?

Of course upstream versions are usually newer but as long as there is no strong reason we not not install those, also since this usually requires a custom source build, and leads to other issues that are hard to solve as unexperienced Linux user.
Post Reply