New Tinker Board S Install - All Browsers Crash

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Milkman Dan
Posts: 16
Joined: Mon Apr 08, 2019 7:04 pm

New Tinker Board S Install - All Browsers Crash

Post by Milkman Dan »

Hello,

I finished installing DietPi on my Tinker Board S last night and all browsers immediately crash on start-up. I've tried both the pre-packaged Firefox ESR and Chromium installs as well as uninstalling and reinstalling them, but they still crash on start-up. I've even tried different desktops to see if that was an issue, but nope.

Any ideas?
Milkman Dan
Posts: 16
Joined: Mon Apr 08, 2019 7:04 pm

Re: New Tinker Board S Install - All Browsers Crash

Post by Milkman Dan »

Chromium error from terminal:

Code: Select all

root@DietPi:/usr/bin# chromium 
[7453:7453:0409/025438.254519:ERROR:gl_surface_egl.cc(949)] eglInitialize Default failed with error EGL_NOT_INITIALIZED
[7453:7453:0409/025438.254647:ERROR:gl_initializer_x11.cc(154)] GLSurfaceEGL::InitializeOneOff failed.
[7453:7453:0409/025438.260341:ERROR:x11_util.cc(110)] X IO error received (X server probably went away)
[7418:7790:0409/025438.437447:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.Notifications.GetCapabilities: object_path= /org/freedesktop/Notifications: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files
[7765:7765:0409/025438.593561:ERROR:gl_surface_egl.cc(949)] eglInitialize Default failed with error EGL_NOT_INITIALIZED
[7765:7765:0409/025438.593700:ERROR:gl_initializer_x11.cc(154)] GLSurfaceEGL::InitializeOneOff failed.
[7765:7765:0409/025438.597226:ERROR:x11_util.cc(110)] X IO error received (X server probably went away)
Received signal 11 SEGV_MAPERR 000000000000
#0 0x00000232ebf0 <unknown>
#1 0x0000022bd4e0 <unknown>
#2 0x00000232ef3e <unknown>
#3 0x00000232f16c <unknown>
#4 0x0000b2cfffe0 <unknown>
#5 0x000000b5814c <unknown>
#6 0x00000261453c <unknown>
#7 0x000002ae550e <unknown>
#8 0x000003705b78 <unknown>
#9 0x0000037061aa <unknown>
#10 0x000003706234 <unknown>
#11 0x00000370626a <unknown>
#12 0x00000218f636 <unknown>
#13 0x00000218f672 <unknown>
#14 0x00000200fc72 <unknown>
#15 0x00000201b80e <unknown>
#16 0x00000201bd10 <unknown>
#17 0x0000010eef70 <unknown>
#18 0x0000013ace9c <unknown>
#19 0x0000010f097e <unknown>
#20 0x0000010f15aa <unknown>
#21 0x0000010e5918 <unknown>
#22 0x000001fe709c <unknown>
#23 0x000001fe7206 <unknown>
#24 0x000001fe7488 <unknown>
#25 0x000001fee3ee <unknown>
#26 0x000001fe5e08 <unknown>
#27 0x0000009d4510 ChromeMain
#28 0x0000b2cf14aa __libc_start_main
[end of stack trace]
Calling _exit(1). Core file will not be generated.
root@DietPi:/usr/bin# [7822:7822:0409/025438.992702:ERROR:gl_surface_egl.cc(949)] eglInitialize Default failed with error EGL_NOT_INITIALIZED
[7822:7822:0409/025438.992825:ERROR:gl_initializer_x11.cc(154)] GLSurfaceEGL::InitializeOneOff failed.
[7822:7822:0409/025438.996557:ERROR:x11_util.cc(110)] X IO error received (X server probably went away)
Firefox error from terminal:

Code: Select all

root@DietPi:/usr/bin# firefox
ExceptionHandler::GenerateDump cloned child 8335
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
root@DietPi:/usr/bin# Failed to open curl lib from binary, use libcurl.so instead
Milkman Dan
Posts: 16
Joined: Mon Apr 08, 2019 7:04 pm

Re: New Tinker Board S Install - All Browsers Crash

Post by Milkman Dan »

Found a workaround on the Tinkerboarding forum for Chromium: https://tinkerboarding.co.uk/forum/post ... ml#pid7840
User avatar
MichaIng
Site Admin
Posts: 2422
Joined: Sat Nov 18, 2017 6:21 pm

Re: New Tinker Board S Install - All Browsers Crash

Post by MichaIng »

@Milkman Dan
Which solution in particular was it? The new Chromium version for TinkerOS or --use-gl=egl? Perhaps it's even removing --use-gl=egl from the default flags.
Milkman Dan
Posts: 16
Joined: Mon Apr 08, 2019 7:04 pm

Re: New Tinker Board S Install - All Browsers Crash

Post by Milkman Dan »

Oops. Yeah, probably should have specified which thing worked. Duh.

It was the v67 package he had in his Dropbox link. The newer versions all crash.
Post Reply