DietPi-Software | 7za command missing on current RPi image Topic is solved

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
greenpop
Posts: 3
Joined: Fri Mar 15, 2019 3:31 pm

DietPi-Software | 7za command missing on current RPi image

Post by greenpop » Fri Mar 15, 2019 3:35 pm

While trying to install Ampache via dietpi-software I get the following error:

│ DietPi-Software: 7za x -y 7.7z -offmpeg_rpi
│ - Exit code: 127
│ - DietPi version: v6.21.1 (MichaIng/master) | HW_MODEL:3 | HW_ARCH:2 | DISTRO:4
│ - Image creator: DietPi Core Team
│ - Pre-image: Raspbian Lite

│ Log file contents:
│ /DietPi/dietpi/func/dietpi-globals: line 1373: 7za: command not found



│ Unable to continue, DietPi-Software will now terminate.

****

The installation worked flawlessly before the recent DietPi update/upgrade (3/15/19).
I hope this helps with fixing the issue. If you have a quick solution please let me know.

Thank you for all the hard work everyone puts into DietPi.

Thank you

greenpop
Posts: 3
Joined: Fri Mar 15, 2019 3:31 pm

Re: Ampache install bug.

Post by greenpop » Fri Mar 15, 2019 5:39 pm

Some more info:


[ OK ] DietPi-Software | Connection test: https://dietpi.com/downloads/binaries/rpi/ffmpeg_rpi.7z
[ OK ] DietPi-Software | wget https://dietpi.com/downloads/binaries/rpi/ffmpeg_rpi.7z -O 7.7z
[FAILED] DietPi-Software | 7za x -y 7.7z -offmpeg_rpi

greenpop
Posts: 3
Joined: Fri Mar 15, 2019 3:31 pm

Re: Ampache install bug.

Post by greenpop » Fri Mar 15, 2019 10:14 pm

Fixed!

The fix as follows:

1) apt update
2) apt install p7zip-full

Now the installation will work.

This is the fix to install Ampache via dietpi-software for their 3/3/19 release.

User avatar
MichaIng
Legend
Posts: 1014
Joined: Sat Nov 18, 2017 5:21 pm

Re: Ampache install bug.

Post by MichaIng » Sat Mar 16, 2019 10:27 pm

@greenpop
Thanks for reporting issue and solution.

Jep this was a mistake of me when creating the new RPi image: https://github.com/MichaIng/DietPi/issues/2631

DietPi v6.22 will be released soon which resolves the issue by using 7zr instead of 7za, which is what the new image preparation script was already expecting ;).

Post Reply