Unable to set RO to RootFS

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
klaas4
Posts: 1
Joined: Mon Mar 04, 2019 10:14 am

Unable to set RO to RootFS

Post by klaas4 »

Hi everyone,

I'm trying to enable RO with the DietPi Drive manager on the root fs, but it says that the fs is busy. If I kill lxdesession and realvnc server it comes up with a message that it is already RO and that it needs to set the fs to RW before it can continue. Meanwhile in /etc/fstab the fs is defined as RW.

So anyone has an idea to convince Dietpi to set the RO options, or what could be preventing it from doing so?

I'm running the latest release of Dietpi on a Raspberry PI 3+, 16GB Sandisk card, running dropbear, vnc server, lxde and a NodeJS application, but I also killed that before trying to set the RO option. I also tried setting the autostart option to 0 (console manual login)

Could I also set the Fstab options manually? And, in general, would this RO setup actually work? Since I'm using a desktop manager as well, would that not complain about a RO fs? Maybe I even need another method of doing RO anyway?

Hope you can help me, thanks in advance!

Kind regards,

EDIT: Saw this on Github https://github.com/MichaIng/DietPi/issues/2604 Do I need to try the beta version for this issue?
User avatar
MichaIng
Site Admin
Posts: 2295
Joined: Sat Nov 18, 2017 6:21 pm

Re: Unable to set RO to RootFS

Post by MichaIng »

@klaas4
You would need to make this change/addition manually to your /DietPi/dietpi/dietpi-drive_manager file: https://github.com/MichaIng/DietPi/comm ... 63b57e8d5b

Otherwise we will release v6.22 Beta tonight, so it's properly easier to wait for this :).
Post Reply