Video playback issues in Kodi on XU4

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
ThrottleItOut
Posts: 4
Joined: Fri Feb 08, 2019 3:41 am

Video playback issues in Kodi on XU4

Post by ThrottleItOut »

I'm running the latest version of dietpi with kodi (pretty much vanilla Krypton) on an XU4. For some videos it plays great, other it lags terribly (several seconds between frames). All videos are stored on an externally powered hard drive connected via usb3. 0.The same videos play fine using vlc media player on another system. It does the same thing on every video played through the YouTube plug in - definitely not an internet speed issue (the buffering bar far outpaces the rate of play). I've seen a lot of other people solve this issue by disabling hardware decoding, but with the Kodi settings option set to "expert" I still have no option to disable it. Why is this, and is there a way around it?
User avatar
MichaIng
Site Admin
Posts: 2294
Joined: Sat Nov 18, 2017 6:21 pm

Re: Video playback issues in Kodi on XU4

Post by MichaIng »

Hmm, actually hardware decoding should assure high resolution videos to play smoothly instead of the other way round :?.

Do you use a current DietPi Stretch image, or is it Jessie and was it flashed a longer time ago?

On Stretch hardware decoding did not work a while back. This is resolved with the current image. AFAIK a simply kernel upgrade (apt full-upgrade) should make this work now.

Please also paste your kernel version:

Code: Select all

uname -a
dpkg -l | grep 'linux-image'
ThrottleItOut
Posts: 4
Joined: Fri Feb 08, 2019 3:41 am

Re: Video playback issues in Kodi on XU4

Post by ThrottleItOut »

I just downloaded the image from the dietpi website Thursday night. Do you still need the kernel info?
User avatar
MichaIng
Site Admin
Posts: 2294
Joined: Sat Nov 18, 2017 6:21 pm

Re: Video playback issues in Kodi on XU4

Post by MichaIng »

Yes please, since the image is quite some months old and the kernel got updated in between most likely.

Also please try to force a kernel update, since I am not sure if this is done via normal apt upgrade/dietpi-update as well:
apt full-upgrade
ThrottleItOut
Posts: 4
Joined: Fri Feb 08, 2019 3:41 am

Re: Video playback issues in Kodi on XU4

Post by ThrottleItOut »

I ran the upgrade code you posted, it says it's already up to date.

The kernel query output is:

4.14.66+ #1 SMP PREEMPT Thu Aug 23 05:59:33 UTC 2018 armv71 GNU/Linux"

Thank you for taking the time to help, I appreciate it!
alexr
Posts: 3
Joined: Fri Feb 22, 2019 10:18 pm

Re: Video playback issues in Kodi on XU4

Post by alexr »

I will open my own thread, but I just wanted to say that I have the exact same problem with Kodi video playback on Odroid XU4 using an external HDD USB 3.0 (read speed > 100MB/s), and I have the latest dietpi version (fresh-intalled yesterday). It's incapable of playing any video beyond the first few seconds. Seems to be a GPU-related problem because I can play the videos on Plex.
Post Reply