dietpi-cam

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

dietpi-cam

Post by johnvick »

Just setup a Pi2 with a new pi cam and dietpi of course - thanks Fourdee - all working nicely.

Is it possible to change the default port?

And any way of switching off the red LED?
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: dietpi-cam

Post by Fourdee »

johnvick wrote:Just setup a Pi2 with a new pi cam and dietpi of course - thanks Fourdee - all working nicely.

Is it possible to change the default port?

And any way of switching off the red LED?
Hi John,

LED

Code: Select all

dietpi-config 
select Display options > RPI Camera led then reboot

dietpi-cam uses the default webserver port of 80. You'd need to edit the webserver configuration file and set another port. If I get a chance later i'll take a indepth look and get back to you.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
User avatar
johnvick
Legend
Posts: 693
Joined: Wed Jun 08, 2016 11:53 am
Location: New Zealand

Re: dietpi-cam

Post by johnvick »

Hi Fourdee,

Thanks for this - the port solution, which you have confirmed, came to me in the middle of the night - I realised it was the lighttpd default port. I had been sidetracked by other pages about the motion software and how it uses port 8081, which I couldn't see any reference to in dietpi. And thanks for the tip about the LED.

John
Post Reply