RPi First Time Install Observations / Issues

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
cancunia
Posts: 2
Joined: Mon Dec 03, 2018 1:01 pm

RPi First Time Install Observations / Issues

Post by cancunia »

Hi, my first post. I've been trying to install Diet-Pi 6.18.14 over the weekend and ran into a problem or two, thought that my first time user experience may be of interest.

1, dietpi.txt / dietpi-wifi.txt
Why not leave the SSID & Pass info in dietpi.txt as per earlier releases, then use that info to populate dietpi-wifi.txt?

2, Install with Ethernet
I made the mistake of not updating the text files before my first boot so I used an ethernet cable, then added WiFi via the config screens. The problem that gave me was that I could only connect to the Pi with the Ethernet cable plugged in. Somehow the WiFi was connected & had an IP address but not active. Trying to connect without the Ethernet cable gave 'No Route to Host' on Putty. If I plugged the Ethernet cable back in, I could login to the Pi via the Ethernet or WiFi address.

3, Config Menus
For a first time user, it took a while to realise that there were more options than appear on the menu. Easy enough to scroll down once you realise, but if possible it would be good to have all of the menu visible by default.

4, MPD
MPD only binds to 'Localhost' out of the box, took me a while to work out that I needed to comment that line out before external clients could use MPD. To be fair, I think this may be the way it comes as standard, but perhaps a change could be made, or documented on the bespoke version.

Otherwise, many thanks for a neat distro. MPD & Cantata running just fine!
Post Reply