[Solved] Grafana installer script issue

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
Warmbadger
Posts: 4
Joined: Mon Nov 19, 2018 1:17 am

[Solved] Grafana installer script issue

Post by Warmbadger »

I thought I'd share an experience I had while installing Grafana through dietpi-software. After the install I was unable to login to the web ui - it kept saying unknown user and password. After digging through the config I discovered that because my password contained a # sign the config file had to use """ 3 quotes before and after """. The install script wasn't adding them so the password wasn't registering.

Uninstalling and setting my default password to something without a # fixed the issue.

Great software, thanks for developing dietpi.
User avatar
MichaIng
Site Admin
Posts: 2294
Joined: Sat Nov 18, 2017 6:21 pm

Re: Grafana installer script issue

Post by MichaIng »

@Warmbadger
Thanks for your report. We will check how to best add the password to Grafana config file and resolve with v6.18: https://github.com/Fourdee/DietPi/issues/2267

€: Moved to topic to better fitting "Troubleshooting" category.

Resolved: https://github.com/Fourdee/DietPi/commi ... 733597c6c6
- Will be soon available in upcoming beta v6.18.10: https://github.com/Fourdee/DietPi/issues/2211
Post Reply