Cron <root@DietPi> /usr/local/sbin/rock64_fix_performance.sh

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
Post Reply
pinito
Posts: 1
Joined: Thu Oct 11, 2018 5:47 pm

Cron <root@DietPi> /usr/local/sbin/rock64_fix_performance.sh

Post by pinito »

I have noticed that every-time I reboot my rock64, I get a cron's email to my gmail account.

I have set up few cron jobs myself but even though they are disabled now, I keep getting this email from cron..

Could anyone help me out to understand this "strange" behavior?

I am attaching below my smtp.conf file

Code: Select all

#
# Config file for sSMTP sendmail
#
# The person who gets all mail for userids < 1000
# Make this empty to disable rewriting.
root=postmaster

# The place where the mail goes. The actual machine name is required no 
# MX records are consulted. Commonly mailhosts are named mail.domain.com
mailhub=smtp.gmail.com:587

# Where will the mail seem to come from?
#rewriteDomain=

# The full hostname
hostname=rock64

# Are users allowed to set their own From: address?
# YES - Allow the user to specify their own From: address
# NO - Use the system generated From: address
#FromLineOverride=YES

Authuser=************@gmail.com
AuthPass=***********
UseTLS=YES
UseSTARTTLS=YES
This is the cron's email that I get every-time I reboot my machine.
In case you are wondering, I do not have this behavior with other distros.
Attachments
cron's email
cron's email
User avatar
MichaIng
Site Admin
Posts: 2293
Joined: Sat Nov 18, 2017 6:21 pm

Re: Cron <root@DietPi> /usr/local/sbin/rock64_fix_performance.sh

Post by MichaIng »

Hmm, not much experience with local mails, but the default hostname on DietPi images is "DietPi".

So if the mail goes to user@host non-case-sensitive, this would be root@dietpi.

So now you configured smtp with "hostname=rock64", so is "rock64" really the correct hostname? To check: cat /etc/hostname

Also it is recommended to use the FQDN as hostname, e.g. host.domain.org
You can change it via: dietpi-config > Security Options > Change Hostname
Post Reply