SABnzbd failure on 6.15

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
sfishe
Posts: 8
Joined: Wed Jul 25, 2018 9:02 am

SABnzbd failure on 6.15

Post by sfishe »

Just updated to DietPi 6.15 and after the reboot SABnzbd fails to load properly. The error seen with 'dietpi-services status' :

Code: Select all

[FAILED] DietPi-Services | sabnzbd      failed (Result: exit-code) since Thu 2018-09-13 10:58:21 AEST; 3s ago
● sabnzbd.service - sabnzbd DietPi
   Loaded: loaded (/etc/systemd/system/sabnzbd.service; disabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2018-09-13 10:58:21 AEST; 3s ago
  Process: 5634 ExecStart=/usr/bin/python /etc/sabnzbd/SABnzbd.py -f /etc/sabnzbd/sabnzbd.ini (code=exited, status=2)
 Main PID: 5634 (code=exited, status=2)

Sep 13 10:58:20 DietPi systemd[1]: Started sabnzbd DietPi.
Sep 13 10:58:21 DietPi python[5634]: Fatal error:
Sep 13 10:58:21 DietPi python[5634]:   Unable to bind to port 8080 on localhost. Some other software uses the port or SABnzbd is already running.
Sep 13 10:58:21 DietPi systemd[1]: sabnzbd.service: Main process exited, code=exited, status=2/INVALIDARGUMENT
Sep 13 10:58:21 DietPi systemd[1]: sabnzbd.service: Unit entered failed state.
Sep 13 10:58:21 DietPi systemd[1]: sabnzbd.service: Failed with result 'exit-code'.

Any thoughts?
sfishe
Posts: 8
Joined: Wed Jul 25, 2018 9:02 am

Re: SABnzbd failure on 6.15

Post by sfishe »

I tried a manual reinstall with: dietpi-software reinstall 139

That process failed near the end, outputting:

Code: Select all

[ SUB2 ] DietPi-Process_tool > Apply
pgrep: only one pattern can be provided
Try `pgrep --help' for more information.
[FAILED] DietPi-Process_tool | Plex Media Server () : Affinity  0-7
[FAILED] DietPi-Process_tool | SABnzbd () : Affinity  0-7
[FAILED] DietPi-Process_tool | An issue has occurred
And then the sabnzbd services still fails with the same error output as before.
sfishe
Posts: 8
Joined: Wed Jul 25, 2018 9:02 am

Re: SABnzbd failure on 6.15

Post by sfishe »

For posterity: resolved - I had installed the Ubiquity Unifi controller, and the java for that binds to port 8080. This wasn't a problem until a reboot where java must have bound the port before SABnzbd. I just changed SABnzbd's port in /etc/sabnzbd/sabnzbd.ini
Post Reply