Plex media server web interface not working.. Topic is solved

Have some feedback, questions, suggestions, or just fancy a chat? Pop it in here.
mefistos

Plex media server web interface not working..

Post by mefistos »

Hi there guys... I have been using dietpi for few weeks now and without any trouble... I have been using plex via kodi addon plexmbc and it was working just fine... but now that there was an official support for plex I wanted to try it... After I installed it and rebooted I am not able to open the web interface.. I can see the plex icon in the browser tab bat thats it.. I am getting this Error:
This site can’t be reached

192.168.1.112 refused to connect.


What am I missing? :?
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Plex media server web interface not working..

Post by Fourdee »

mefistos wrote:Hi there guys... I have been using dietpi for few weeks now and without any trouble... I have been using plex via kodi addon plexmbc and it was working just fine... but now that there was an official support for plex I wanted to try it... After I installed it and rebooted I am not able to open the web interface.. I can see the plex icon in the browser tab bat thats it.. I am getting this Error:
This site can’t be reached

192.168.1.112 refused to connect.


What am I missing? :?
Hi mefistos,

Thanks for the report.
Which device are you running (eg: Odroid C2, RPi 2)? I'll see if I can replicate at my end.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
mefistos

Re: Plex media server web interface not working..

Post by mefistos »

Fourdee wrote:
mefistos wrote:Hi there guys... I have been using dietpi for few weeks now and without any trouble... I have been using plex via kodi addon plexmbc and it was working just fine... but now that there was an official support for plex I wanted to try it... After I installed it and rebooted I am not able to open the web interface.. I can see the plex icon in the browser tab bat thats it.. I am getting this Error:
This site can’t be reached

192.168.1.112 refused to connect.


What am I missing? :?
Hi mefistos,

Thanks for the report.
Which device are you running (eg: Odroid C2, RPi 2)? I'll see if I can replicate at my end.
Hi Fourdee,

its on RPi 2...
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Plex media server web interface not working..

Post by Fourdee »

Thanks,

Works fine my end. Silly question, did you add the :32400/web to the url address, as per the documentation?
http://192.168.1.112:32400/web
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
mefistos

Re: Plex media server web interface not working..

Post by mefistos »

Fourdee wrote:Thanks,

Works fine my end. Silly question, did you add the :32400/web to the url address, as per the documentation?
http://192.168.1.112:32400/web
I sure did:D I also had plexmediaserver already installed but from different source... as now when I am manually typing the http://192.168.1.112:32400/web address it gives me :
http://192.168.1.112:32400/web/index.html#
http://192.168.1.112:32400/web/index.html#!/status
options... So the question is if it remembers the previous settings and if it does.. why cant I access the web interface again... I wonder If I should do apt-get --purge remove plexmediaserver and try again...
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Plex media server web interface not working..

Post by Fourdee »

mefistos wrote:I also had plexmediaserver already installed but from different source
I wonder If I should do apt-get --purge remove plexmediaserver and try again...
Yep, if it was a .deb install, purge should do it. Don't need to use "remove" with purge:

Code: Select all

apt-get purge plexmediaserver
Then reinstall.
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
mefistos

Re: Plex media server web interface not working..

Post by mefistos »

Fourdee wrote:
mefistos wrote:I also had plexmediaserver already installed but from different source
I wonder If I should do apt-get --purge remove plexmediaserver and try again...
Yep, if it was a .deb install, purge should do it. Don't need to use "remove" with purge:

Code: Select all

apt-get purge plexmediaserver
Then reinstall.
still not working... i am lost.. is there anything else I could try?
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Plex media server web interface not working..

Post by Fourdee »

mefistos wrote:
Fourdee wrote:
mefistos wrote:I also had plexmediaserver already installed but from different source
I wonder If I should do apt-get --purge remove plexmediaserver and try again...
Yep, if it was a .deb install, purge should do it. Don't need to use "remove" with purge:

Code: Select all

apt-get purge plexmediaserver
Then reinstall.
still not working... i am lost.. is there anything else I could try?
Can you link the guide you followed to install Plexmediaserver previously? There might be something we can find.

Also, please can you send a bug report?
This will send me your system settings which might put us on the right track. No need to fill out the document, simply paste the reference CODE in your reply.

Code: Select all

dietpi-bugreport
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
mefistos

Re: Plex media server web interface not working..

Post by mefistos »

Fourdee wrote: Can you link the guide you followed to install Plexmediaserver previously? There might be something we can find.

Also, please can you send a bug report?
This will send me your system settings which might put us on the right track. No need to fill out the document, simply paste the reference CODE in your reply.

Code: Select all

dietpi-bugreport
I believe this is the guide I was using to get the plex server working before :http://www.htpcguides.com/install-plex- ... erry-pi-2/

and this is the reference code: dbaa9a99-484e-46a3-8894-8e5c3a4fa94b-0
User avatar
Fourdee
Site Admin
Posts: 2788
Joined: Tue Feb 06, 2007 1:36 pm

Re: Plex media server web interface not working..

Post by Fourdee »

Thanks,

These need removing before installing from dietpi-software:

Code: Select all

rm /etc/apt/preferences.d/jessie.pref
rm /etc/apt/sources.list.d/pms.list
apt-get clean
apt-get update
Uninstall plex from dietpi:

Code: Select all

dietpi-uninstall
Reinstall plex:

Code: Select all

dietpi-software
Whats your locale?

Code: Select all

locale
If you find our project or support useful, then we’d really appreciate it if you’d consider contributing to the project however you can.
Donating is the easiest – you can use PayPal or become a DietPi patron.
Post Reply