Sound problems in 6.14 with Kodi on Odroid

Having issues with your DietPi installation, or, found a bug? Post it here.
Post Reply
pulldown
Posts: 6
Joined: Tue Oct 17, 2017 5:40 pm

Sound problems in 6.14 with Kodi on Odroid

Post by pulldown »

Hi everyone,

I just updated to 6.14 on my Odroid C2 and discovered a few problems. First, X wouldn't start, complaining about keyboard compilation. OK, so I did an xkb configuration, and that seemed to solve that. After that, however, Kodi will run (xinit kodi-standalone) but has no sound.

The log files indicate that it it can't find pulseaudio:

Code: Select all

12:31:26.237 T:547385540608   ERROR: PulseAudio: Failed to connect context
12:31:26.237 T:547385540608  NOTICE: PulseAudio might not be running. Context was not created.
12:31:26.237 T:547385540608  NOTICE: No Devices found - retry: 4
12:31:27.739 T:547385540608   ERROR: PulseAudio: Failed to connect context
12:31:27.739 T:547385540608  NOTICE: PulseAudio might not be running. Context was not created.
12:31:27.740 T:547385540608  NOTICE: No Devices found - retry: 3
etc.

Looking back at previous dietpi versions, it appears that pulseaudio is a new addition. Also, I notice that a pulse user has been added to the passwd file, which makes me wonder if there is some sort of permissions issue. I tried uninstalling pulseaudio, hoping that it would just automatically fall back to ALSA, but that doesn't seem to happen.

Does anybody have any pointers for either getting pulseaudio working or forcing Kodi to use ALSA?

Thanks for your help, and for all of your work putting DietPi together, which really is a great OS.
pulldown
Posts: 6
Joined: Tue Oct 17, 2017 5:40 pm

Re: Sound problems in 6.14 with Kodi on Odroid

Post by pulldown »

You know, as I look at it further, I wonder if there is some greater problem at work. Sound seems to be broken in a fairly basic way. Here is the output of aplay -l:

Code: Select all

aplay -l
**** List of PLAYBACK Hardware Devices ****
ALSA lib conf.c:3916:(snd_config_update_r) Cannot access file /usr/share/alsa/alsa.conf
ALSA lib control.c:1373:(snd_ctl_open_noupdate) Invalid CTL hw:0
aplay: device_list:279: control open (0): No such file or directory
Clearly some more investigation is needed.
pulldown
Posts: 6
Joined: Tue Oct 17, 2017 5:40 pm

Re: Sound problems in 6.14 with Kodi on Odroid

Post by pulldown »

Never mind. I decided to do a clean install, and HDMI sound seems to be recognized again. How things got so broken is a bit mysterious—I didn't think I was doing anything exotic. But there you have it.
Post Reply